http - сервис (выгрузка файлов обработок)

Публикация № 1271216 29.07.20

Администрирование - Администрирование данных 1С - Сервисные утилиты

http; запрос; сервис; расширение; обработка;post

Цель: обновлять версии обработок в поддерживаемых базах, без траты времени на авторизацию в базе, поиск обработки, и ее обновление (только существующих). Небольшое повествование, о загрузке в сервис файлов обработок и отчетов и их обновление в базе.

Приветствую,

пишу для разработчиков большей частью, к сожалению, не могу выложить полное решение, но сервис загрузки со стороны принимающей стороны универсален (создан расширением, и использует стандартный БСП механизм работы с дополнительными обработками и отчетами).

На создании сервиса, я останавливаться не буду, на ресурсе вполне хватает информации. Первая проблема с какой я столкнулся это, как Передать файл сервису. На "Инфостарте" к сожалению подходящего примера не нашел , но несколько идей мне подкинула обработка которая разбирала НТТП-запрос как поток (Полезно), в другой я взял мысль о передаче двоичных данных в файле.

Что получилось:


	мФайл		=	новый Файл(ПараметрыЗапроса.ПолноеИмяФайла);
	ИмяФайла	=	мФайл.Имя;  	
	
	//Сведения о обработке
	ПараметрыРегистрации	=	новый Структура("ЭтоОтчет,ИмяФайла,АдресДанныхОбработки");
	ПараметрыРегистрации.ЭтоОтчет				=	ВРег(Прав(ИмяФайла,3))="ERF";
	ПараметрыРегистрации.ИмяФайла				=	ИмяФайла;
	ПараметрыРегистрации.АдресДанныхОбработки	=	ПоместитьВоВременноеХранилище(новый ДвоичныеДанные(ПутьФайла));



//Адрес сервиса
	HTTPЗапрос = Новый HTTPЗапрос("/"+ПараметрыЗапроса.ИмяБазы+"/hs/load1c/obj/");
	
	Boundary = СтрЗаменить(Строка(Новый УникальныйИдентификатор()), "-", "");
	
	// передадим данные на сервер 	
	HTTPЗапрос.Заголовки.Вставить("Content-Type"	, "multipart/form-data");	
	HTTPЗапрос.Заголовки.Вставить("boundary"		, boundary);
	HTTPЗапрос.Заголовки.Вставить("fileName"		, ИмяФайла);
	HTTPЗапрос.Заголовки.Вставить("report"			, Формат(ПараметрыРегистрации.ЭтоОтчет,"БЛ=Ложь; БИ=Истина"));
	HTTPЗапрос.Заголовки.Вставить("name_1c_Object"	, ПараметрыРегистрации.Наименование);
	
	//Формирование тела запроса
	// параметр "file"	
	имяФайлаОтправки 	= ПолучитьимяВременногоФайла("txt");		
	ЗаписьТекста 		= Новый ЗаписьТекста(имяФайлаОтправки,КодировкаТекста.UTF8);	
	
	ЗаписьТекста.ЗаписатьСтроку("Content-Disposition: form-data; name=""file""; filename="""+ИмяФайла+"""");
	ЗаписьТекста.ЗаписатьСтроку("Content-Type: binary");
	ЗаписьТекста.ЗаписатьСтроку("start_"+Boundary);
	ЗаписьТекста.Записать(Base64Строка(Новый ДвоичныеДанные(ПутьФайла)));
	ЗаписьТекста.ЗаписатьСтроку("end_"+Boundary);	
	ЗаписьТекста.Закрыть();	
	
	HTTPЗапрос.УстановитьИмяФайлаТела(имяФайлаОтправки);
	
	HTTPОтвет	=	Соединение.ОтправитьДляОбработки(HTTPЗапрос);	
	
	ТелоОтвета	=	СокрЛП(HTTPОтвет.ПолучитьТелоКакСтроку(КодировкаТекста.UTF8));
	
	Если не ПустаяСтрока(ТелоОтвета) Тогда
		Сообщить( ТелоОтвета);
	КонецЕсли;
	
	
	Если 	HTTPОтвет.КодСостояния	=	200 Тогда
		Сообщить("ок");			
	Иначе
		Сообщить("Ошибка отправки запроса");				
	КонецЕсли;

данный пример выполняется на клиенте, для себя я определил это правило, но можно конечно и на сервер отправить,

Для начала я описываю (заголовки запроса, Имя файла, тип обработки, Имя регистрации в базе, а также переменую boundary)

boundary - Уникальный идентификатор, который служит ключом начало и конца будущего тела запроса

Дальше, создаем текстовый файл для тела запроса, первый абзац это служебная информация, дальше мы кодируем в Base64 наши двоичные данные и встраиваем в файл, обрамляя "тегами" начала и конца.

После устанавливаем полученных текстовый файл в тело запроса и отправляем для обработки.

На стороне отправителя мы закончили.

 

Далее со стороны ХТТП сервиса

типовая функция обработки запроса:




Функция uploadpost(Запрос)
	
	СтруктураОтвета	=	ПоместитьВХранилищеФайлИзТелаСтрокиХТТП(Запрос);	
	ЗагрузитьОбъект1С_в_спр_допОбработок(СтруктураОтвета);
	
	Если ПустаяСтрока(СтруктураОтвета.ОписаниеОшибок) Тогда		
		Ответ 			= Новый HTTPСервисОтвет(200);		
		
	иначе
		Ответ 			= Новый HTTPСервисОтвет(500,СтруктураОтвета.ОписаниеОшибок);	
		Ответ.УстановитьТелоИзСтроки(СтруктураОтвета.ОписаниеОшибок, КодировкаТекста.UTF8, ИспользованиеByteOrderMark.НеИспользовать);
	КонецЕсли;
	
	
	Возврат Ответ;
КонецФункции


Функция ПоместитьВХранилищеФайлИзТелаСтрокиХТТП(Запрос)
	СтруктураОтвета	=	Новый Структура("ИмяФайла,АдресХранилища,ОписаниеОшибок,ЭтоОтчет,ИмяОбъекта");
	
	СтруктураОтвета.ИмяФайла	=	Запрос.Заголовки.Получить("fileName");
	СтруктураОтвета.ЭтоОтчет	=	?(Запрос.Заголовки.Получить("report")="Истина",Истина,Ложь);	
	СтруктураОтвета.ИмяОбъекта	=	Запрос.Заголовки.Получить("name_1c_Object");
	
	boundary					=	Запрос.Заголовки.Получить("boundary");	
	РазмерФайла					=	Запрос.Заголовки.Получить("Content-Lenght");	
	
	
	Если ЗначениеЗаполнено(СтруктураОтвета.ИмяФайла) и ЗначениеЗаполнено(boundary) Тогда
		
		ОписаниеОшибки		=	"";
		
		
		ТелоСтрока		=	Запрос.ПолучитьТелоКакСтроку();		
		МаркерНачала	=	"start_"+Boundary;
		ДлиннаМаркера1	=	СтрДлина(МаркерНачала);
		ПозицияНачала	=	СтрНайти(ТелоСтрока,МаркерНачала)+ДлиннаМаркера1+1;
		
		
		МаркерОкончания	=	"end_"+Boundary;			
		ПозицияОкончания=	СтрНайти(ТелоСтрока,МаркерОкончания);
		
		ТелоФайла		=	Сред(ТелоСтрока,ПозицияНачала,ПозицияОкончания-ПозицияНачала);			
		
		Попытка			
			СтруктураОтвета.АдресХранилища	=	ПоместитьВоВременноеХранилище(Base64Значение(ТелоФайла));
		Исключение			
			ОписаниеОшибки	=	ОписаниеОшибки+ОписаниеОшибки();
		КонецПопытки;
		
		СтруктураОтвета.ОписаниеОшибок	=	ОписаниеОшибки;	
		
	КонецЕсли;
	
	Возврат СтруктураОтвета;
	
КонецФункции

Процедура ЗагрузитьОбъект1С_в_спр_допОбработок(СтруктураЗадания)
	
	УстановитьПривилегированныйРежим(Истина);
	Запрос = Новый Запрос;
	Запрос.Текст = 
		"ВЫБРАТЬ ПЕРВЫЕ 1
		|	ДополнительныеОтчетыИОбработки.Ссылка КАК Ссылка
		|ИЗ
		|	Справочник.ДополнительныеОтчетыИОбработки КАК ДополнительныеОтчетыИОбработки
		|ГДЕ
		|	ДополнительныеОтчетыИОбработки.Наименование = &Наименование";
	
	Запрос.УстановитьПараметр("Наименование", СтруктураЗадания.ИмяОбъекта);
	
	РезультатЗапроса 		= Запрос.Выполнить();	
	ВыборкаДетальныеЗаписи 	= РезультатЗапроса.Выбрать();
	
	ХД	=	Новый ХранилищеЗначения(ПолучитьИзВременногоХранилища(СтруктураЗадания.АдресХранилища));
	
	Если ВыборкаДетальныеЗаписи.Следующий() Тогда
		
		СО						=	ВыборкаДетальныеЗаписи.ссылка.ПолучитьОбъект();
		со.ХранилищеОбработки	=	ХД;
		со.Версия				=	формат(ТекущаяДата(),"ДФ=dd/MM/yy");
		СО.Записать();
	Иначе
		СтруктураЗадания.ОписаниеОшибок	=	"Не найдено в доп.обработках: <"+СтруктураЗадания.ИмяОбъекта+">"
		
	КонецЕсли;
	
	УстановитьПривилегированныйРежим(Ложь);
	
КонецПроцедуры

 

тут следует сказать, что я просто помещаю в хранилище данных обработку, согласен, что немного топорно без проверки, можно использовать СведенияОВнешнейОбработке.

 

Тестирование: 

  • Платформа (8.3.12.1685) 
  • Бухгалтерия предприятия, редакция 3.0 (3.0.71.83)

Скачать файлы

Наименование Файл Версия Размер
http - сервис (выгрузка файлов обработок):

.epf 7,36Kb
0
.epf 7,36Kb Скачать
http - сервис (выгрузка файлов обработок):

.cfe 11,90Kb
0
.cfe 11,90Kb Скачать

Специальные предложения

Оставьте свое сообщение

См. также

Удаление и/или копирование сохраненных в 1С настроек (например настроек печати табличных форм) Промо

Универсальные обработки Сервисные утилиты v8 Абонемент ($m)

Иногда нужно удалить сохраненную в 1С "покореженную" настройку или скопировать "удачную" другому пользователю...

1 стартмани

01.09.2012    63163    1368    AnryMc    46    

BIM: взаимодействие с платформой Autodesk Forge

WEB v8 1cv8.cf Строительство Абонемент ($m)

Предлагаемый пример демонстрирует широкие возможности для взаимодействия «1С:Предприятие» с платформой Autodesk Forge и позволяет вам получить базовые представления о применения технологий информационного моделирования в строительстве. Поддерживаются все версии платформы от 8.3.12 и выше до 8.3.18.

1 стартмани

25.11.2020    24364    9    kandr    2    

HTTP сервисы по OpenAPI спецификациям

Практика программирования WEB v8 1cv8.cf Абонемент ($m)

Начинаем путь разработки HTTP сервисов с создания спецификаций OpenAPI. Автодокументация сервисов формата Swagger UI без зависимостей. Настройка сервисов в режиме предприятия.

1 стартмани

29.06.2020    13105    10    shmalevoz    21    

Модуль обмена с QIWI

Банковские операции WEB v8 1cv8.cf УУ Абонемент ($m)

Компании, которые используют систему моментальных платежей QIWI, ценят ее за удобство по скорости выплат и для платежей по запросу. Но такие переводы сложны для учета, а при большом объеме проводимых операций отнимают много времени и превращаются в дополнительную головную боль. Мы сотрудничали с компаниями, которые отправляют большое количество платеже на QIWI, и часто слышали боль бухгалтеров о том, как им сложно работать с такими переводами. Поэтому мы автоматизировали выплаты через QIWI в 1С и создали модуль интеграции 1С c API QIWI Wallet и QIWI TopUp.

5 стартмани

25.05.2020    5297    0    Neti    10    

Внешняя компонента для работы по Web-socket протоколу x32 x64 Промо

Разработка внешних компонент WEB v8 Абонемент ($m)

Кто когда-нибудь сталкивался с обменом данными по Web-Socket (wss) протоколу из 1С, тому известно, что в платформе отсутствуют данные механизмы (не путать с HTTP запросами и WebServices). Предлагается использовать внешнюю компоненту, написанную по технологии NativeAPI, для подключения и обмена с серверами из 1С-Предприятия, работающими по протоколу Web-Socket.

1 стартмани

30.03.2018    33168    49    Ditron    101    

"Учет штрафов ГИБДД" с возможной загрузкой из открытых источников в интернет Расширение конфигурации 1С: Предприятие 8.3

Обработка документов WEB v8 v8::УФ 1cv8.cf Россия БУ УУ Абонемент ($m)

Расширение конфигурации Бухгалтерия предприятия, редакция 3.0 (при минимальных изменениях любой типовой конфигурации), позволяющее вести историю данных по штрафам ГИБДД для справочника транспортных средств компании. Бонусом поставляется внешняя обработка, способная загружать эти данные из открытых источников в интернет.

4 стартмани

30.12.2019    15796    20    capitan    11    

Односторонний файловый обмен с сайтом по ftp (1C 2 Web)

Обмен данными 1С Файловые протоколы обмена, FTP WEB v8 Розница УНФ ERP2 БП3.0 УТ11 КА2 ЗУП3.x Абонемент ($m)

Подходит под любую конфигурацию на управляемом интерфейсе на базе БСП 2.4.4 и выше. Позволяет гибко настроить выгрузку, практически любых, данных по расписанию на сервер ftp вашего ресурса. Ведение лога процесса выгрузки также предусмотрено.

3 стартмани

09.12.2019    9310    12    LamerSoft    0    

Командный интерпретатор для 1С

Сервисные утилиты v8 1cv8.cf Абонемент ($m)

Инструмент для выполнения команд CMD / PowerShell из 1С.

2 стартмани

15.11.2019    16249    31    YPermitin    41    

Трекинг номеров РПО в Почте России Промо

WEB Оптовая торговля Оптовая торговля v8 Оптовая торговля, дистрибуция, логистика Абонемент ($m)

Относительно недавно Почта России стандартизировала и описала сервисы получения информации о регистрируемом почтовом отправлении (РПО). Представляю вашему вниманию конфигурацию-обертку над сервисами Почты России. Она позволяет просто (http-запросы) и без изменений конфигурации подключить сервисы отслеживания к своим информационным системам.

2 стартмани

28.03.2016    30932    38    Smaylukk    3    

Работа с релизами 1С и договорами ИТС

WEB БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Работа с релизами 1С и партнерским кабинетом.

2 стартмани

15.08.2019    18951    56    RocKeR_13    37    

Шаблон http-сервиса для вашего проекта

Внешние источники данных WEB Мобильная разработка v8 v8::Mobile 1cv8.cf Абонемент ($m)

Http-сервис для обмена данными в формате JSON. Обработчики этого сервиса находятся во внешней обработке, что позволяет дорабатывать его без изменения конфигурации. Также прилагаю пример мобильного приложения для работы с данным сервисом (получает номенклатуру и остатки на складе). Сервис очень быстро разворачивается и масштабируется под ваши задачи.

3 стартмани

04.05.2019    24203    88    MarkoSokolov    48    

Блин, мы забыли включить регламентные задания…

Сервисные утилиты v8 Абонемент ($m)

Привет, Инфостарт! Сегодня расскажу, как я решил проблему с выключенными регламентными заданиями в рабочих базах. Желая исключить человеческий фактор и минимизировать количество ошибок, я написал небольшую конфигурацию.  В конфигурации два регламентных задания. Первое периодически подключается к кластеру и сохраняет текущие параметры: имя, Сервер БД, базу СУДБ, блокировки входа и регламентных заданий и т.д. Второе задание периодически проверяет эти параметры на ошибки.

1 стартмани

08.04.2019    22643    19    slozhenikin_com    37    

Работа с картой. Кадастровый учет (Росреестр). Тематические карты Промо

WEB Рабочее место v8 v8::УФ 1cv8.cf Абонемент ($m)

Внешняя обработка для работы с картами в 1С. Получения изображения с публичной кадастровой карты России, построения тематических карт

1 стартмани

31.08.2017    23097    13    vipchep    1    

1С и WebKit. Вариант взаимодействия

WEB v8 1cv8.cf Абонемент ($m)

В результате перехода на WebKit тип свойства Документ у поля, имеющего вид ПолеHTMLДокумента, изменился с COMОбъект на ВнешнийОбъект. Также изменилась DOM модель документа, доступная через это свойство.

2 стартмани

23.02.2019    37596    84    mi1man    59    

Строим маршруты на картах в 1С с помощью OpenStreetMap, OSRM и Leaflet

WEB v8 1cv8.cf Транспорт, автопарки, такси Абонемент ($m)

Краткая статья о том как вывести на карту (в 1С) маршруты с помощью OpenStreetMap, OSRM и Leaflet. По данной системе очень мало примеров, но так как OpenStreetMap является бесплатным сервисом и не требует никаких ключей и регистраций, и является довольно мощным механизмом, решил написать небольшую статью "как это сделать?". В первую очередь скажу, все намного проще, если вы используете последнюю версию платформы (8.3.14), где есть поддержка практически всех браузеров (IE 11, EDGE, Mozilla), но что делать если у нас не самая свежая платформа, где поддержка только IE 9?

2 стартмани

12.02.2019    33834    116    Ditron    105    

LicDataDecoder - расшифровка файла программной лицензии 1С

Сервисные утилиты v8 1cv8.cf Россия Абонемент ($m)

Представляю вашему вниманию утилиту, предназначенную для работы с файлами программных лицензий 1С (*.lic).

1 стартмани

10.02.2019    46173    402    GeraltSnow    62    

Универсальный монитор лицензий 1С

Сервисные утилиты v8 1cv8.cf Абонемент ($m)

Хотите узнать, какие программные лицензии установлены на сервере и все их технические подробности? А может быть, вам нужна информация по использованию всех видов лицензий кластера? Нет ничего проще, читай далее, чтобы быть в курсе!

3 стартмани

03.01.2019    43964    407    Xershi    79    

Легкое и гибкое управление списком доступных баз 1С у пользователей

Стартеры 1С Сервисные утилиты Администрирование СУБД v8 1cv8.cf Россия Абонемент ($m)

Когда в локальной сети много пользователей, а еще большое количество различных баз и при этом каждому нужны свои, то администрирование этого зоопарка превращается в АД! Этот комплекс позволяет централизованно управлять списком доступных баз в разрезе пользователей. За пару кликов можно добавить или убрать базу у всех пользователей.

7 стартмани

05.12.2018    19794    21    RomikR    9    

Проверка VAT номеров

WEB v8 1cv8.cf Абонемент ($m)

Обработка для вызова сервиса проверка VAT номера.

1 стартмани

26.11.2018    16508    3    wtlz    1    

Очистка кэша 1С 8 (8.0, 8.1, 8.2, 8.3). Грамотная чистка кэша 1С с сохранением настроек.

Чистка базы Сервисные утилиты Администрирование данных 1С v8 1cv8.cf Россия Абонемент ($m)

Эффективное средство для устранения ошибок, возникающих в локальном кэше 1С на клиенте, которым легко сможет воспользоваться пользователь с любым уровнем знаний. Wsf-скрипт, созданный на стандартном языке автоматизации Windows - "WSH JScript", очищает кэш 1С просто, быстро и безопасно. Кроме варианта, очищающего кэш текущего пользователя, имеется также вариант для чистки кэша 1С всех пользователей терминального-сервера.

1 стартмани

04.11.2018    49640    484    Eugen-S    34    

Обнаружено нарушение целостности системы

Сервисные утилиты v8 1cv8.cf Россия Абонемент ($m)

Ошибка «Обнаружено нарушение целостности системы», причины и варианты устранения ошибки.

1 стартмани

03.10.2018    200854    992    Palmer1976    69    

Работа с публикациями "Инфостарт"

Практика программирования О сообществе WEB v8 УУ Абонемент ($m)

Работа с рублевыми публикациями на сайте "Инфостарт": ведение клиентов, заказов, обновление файлов публикации, рассылка обновлений.

1 стартмани

13.09.2018    26315    14    RocKeR_13    16    

SOAP для чайников

Обмен через XML WEB v8 1cv8.cf Абонемент ($m)

Немножко про SOAP сервис. И пример работы с подключением и получением данных по SOAP за 5 минут.

1 стартмани

05.09.2018    72138    53    dusha0020    19    

1C + Arduino + сканер отпечатков пальцев + RFID считыватель

Терминал сбора данных Сервисные утилиты Учет рабочего времени Учет рабочего времени NFC, RFID v8 1cv8.cf Абонемент ($m)

Связываем 1C, Arduino, сканер отпечатков пальцев и RFID считыватель для системы учёта рабочего времени или пропускной системы.

1 стартмани

21.08.2018    28617    15    DGorgoN    39    

Класс-обработка “Работа с картами Яндекс”

Разработка внешних компонент WEB v8 Абонемент ($m)

Как показать точку или маршрут на карте Яндекс. Как получить координаты по строке адреса (геокодирование).

1 стартмани

01.08.2018    31880    229    RSConsulting    17    

Пример использования REST API Яндекс Диска

WEB v8 1cv8.cf Абонемент ($m)

Пример использования REST API Яндекс Диска: чтение диска, добавление каталога, загрузка файла, скачивание файлов или каталогов, удаление файлов или каталогов.

1 стартмани

26.06.2018    31460    49    MKFreeUser    15    

Обмен файловыми базами данных через Yandex диск

WEB v8 Россия Абонемент ($m)

Выполнение операций обмена с Yandex диском для файловых БД, по протоколу WebDav, в автоматическом или ручном режимах.

1 стартмани

11.06.2018    20254    7    slimper    1    

Чтение сжатого gzip, deflate HTTP ответа сервера. Без ВК. Уменьши время загрузки и сократи трафик в 3 раза

WEB v8 1cv8.cf Абонемент ($m)

В платформе 1С:Предприятие не реализовано штатного механизма декодирования ответа веб серверов, в которых присутствует gzip сжатие. Некоторые использовали WinHttpRequest.5.1 , кто-то писал ВК. Друзья, хватит. Вот вам решение.

1 стартмани

08.06.2018    19779    99    Malfarion    22    

Конфигурация для просмотра публичных телеграм каналов

WEB v8 Абонемент ($m)

Просмотр и каталогизация в более удобном виде публичных телеграм каналов, групп и чатов.

1 стартмани

02.06.2018    21264    13    DO_WHILE_LOOP    7    

Интеграция между Atlassian Jira и 1С:Предприятие 8.3 используя Jira REST API (выборка, создание и изменение запросов, чтение, создание и удаление записей о работах, чтение комментариев и другие возможности)

Внешние источники данных WEB v8 v8::УФ 1cv8.cf Абонемент ($m)

Внешняя обработка на управляемой форме для 1С:Предприятие 8.3 по интеграции с Atlassian Jira используя Jira REST API. Ключевые функции: выборка запросов с использованием JQL; добавление и изменение запросов; добавление, изменение и удаление записей о работах; чтение комментариев к запросам; сохранение всех ключевых параметров между сеансами работы. Тестирование проводилось на платформе 1С (8.3.11.2954) совместно с JIRA Server platform (7.3.7)

1 стартмани

24.04.2018    40552    231    Ko1t    86    

Простая и пошаговая интеграция Яндекс-Алисы и 1С

WEB v8 Абонемент ($m)

Интеграция Алисы и 1С через http сервис на платформе 8.3.9. Используем виртуальный сервер, сертификат от letsencrypt, и делаем простые запросы к базе из Алисы.

1 стартмани

09.04.2018    26928    25    kiv1c    36    

Чтение и запись из таблиц гугл (google sheets) в табличный документ 1С (8.3, управляемые формы)

Внешние источники данных WEB v8 v8::УФ 1cv8.cf Абонемент ($m)

Внешняя обработка на управляемой форме для 1С версии 8.3 для доступа к сервисам Google Sheets c использованием протокола авторизации OAuth 2.0. Выполняет получение списка листов таблицы гугл, чтение таблицы гугл в табличный документ 1С и запись из табличного документа 1С в таблицу гугл. Тестирование проводилось на платформе 1С:Предприятие 8.3 (8.3.11.2954).

1 стартмани

09.04.2018    50427    342    Ko1t    82    

Построение маршрута доставки с расчётом расстояния для любой базы УФ

Универсальные обработки WEB Оптовая торговля Оптовая торговля v8 v8::УФ 1cv8.cf Абонемент ($m)

Графическое изображение маршрутного листа по картам гугл. Работает на любой конфигурации с управляемыми формами. Использует новую версию api google-карт от 13.02.2018 года под IE11.

10 стартмани

24.02.2018    41220    46    KorotkovRV    16    

Сервер push сообщений “Push0k“ 18.05

WEB v8 1cv8.cf Абонемент ($m)

Аналог других “мессенджеров“. Позволяет практически все то же самое, что и другие решения. За исключением смайлов, эмодзи, голосовой и видео связи. Основное отличие от других решений, открыта и доступна для изменения серверная и клиентская часть месенджера. Общедоступной серверной части нет, за серверную часть отвечаете вы сами.

1 стартмани

19.12.2017    21609    12    PloAl    20    

Быстрое удаление неиспользуемых версий 1С:Предприятие 8, кэша метаданных и информационных баз

Сервисные утилиты v8 Абонемент ($m)

При обновлении платформы 1С:Предприятие 8 предыдущие версии не удаляются. Со временем количество неиспользуемых версий платформы растет. Они занимают место на диске. Для решения этой проблемы предназначена программа OneCleaner. Она позволяет быстро удалить неиспользуемые версии платформы, а также почистить кэш метаданных и удалить ненужные информационные базы данных.

1 стартмани

14.11.2017    26417    96    bonv    15    

Проверка орфографии средствами Yandex Speller

Универсальные обработки WEB v8 1cv8.cf Абонемент ($m)

Проверка орфографии средствами Yandex Speller с опциями и коррекцией ошибок. Возможность вызова как с сервера, так и с клиента (с последующим исправлением).

1 стартмани

09.11.2017    28908    61    🅵🅾️🆇    41    

V8 Log Scanner - утилита для быстрого парсинга логов ТЖ

Сервисные утилиты Технологический журнал v8 Россия Абонемент ($m)

Как можно быстро настраивать logcfg.xml и парсить логи технологического журнала с помощью самописной open-source утилиты V8LogScanner. Без необходимости погружаться в регулярные выражения.

1 стартмани

07.11.2017    23269    5    ripreal1    27    

Графическая оболочка для консольной утилиты cnvdbfl.exe

Сервисные утилиты v8 Абонемент ($m)

Графическая оболочка для консольной утилиты cnvdbfl.exe предназначенной для преобразования размера внутренней страницы файла базы 1С.

2 стартмани

25.10.2017    45127    310    frkbvfnjh    44    

Ведение локального каталога обработок с Инфостарт

Универсальные обработки WEB v8 1cv8.cf Абонемент ($m)

Обработка наводит порядок в ваших скачанных и локально хранимых обработках с Инфостарта. Это особенно удобно тем коллегам, которые уже скачали немалый объем обработок и хотят получить удобный инструмент навигации по списку.

1 стартмани

06.10.2017    33060    62    rpgshnik    48    

Подсистема Вики - интеграция 1С и сайта под управлением MediaWiki

WEB v8 Абонемент ($m)

Редактирование статей сайта Mediawiki из 1С. Формирование функционального описания конфигурации на сайте Вики.

1 стартмани

19.09.2017    32220    35    shmalevoz    20    

ОСкрипты для деплоя и копирования базы данных

Сервисные утилиты v8 1cv8.cf Абонемент ($m)

Набор оскриптов для деплоя базы 1С через хранилище и копирование через sql-бекап одной базы в другую

1 стартмани

02.05.2017    27628    38    Stepa86    29