Компонента аутентификации и шифрования с помощью биометрической информации для Андроид

Публикация № 1120028 17.09.19

Интеграция с оборудованием и сервисами - Разработка внешних компонент

биометрическая информация внешняя компонента

Компонента для мобильной платформы, позволяющая идентифицировать пользователя и шифровать данные с помощью биометрических сканеров.

В мобильных приложениях часто бывает необходимо хранить секретную информацию, например пароли. Если записывать ее в базу данных, всегда нужно учитывать риск утери устройства и, соответственно, возможность доступа к ней посторонних лиц. В мобильных операционных системах существуют механизмы защиты ключей шифрования паролями, порождаемыми биометрическими сканерами. Если подробнее, информация шифруется ключом с паролем из хеша, полученного из сканера. Для расшифровки извлеченный из хранилища ключ должен быть "подписан" тем же отпечатком. Данная компонента позволяет воспользоваться такими механизмами ОС Андроид.

Стандартный диалог запроса биометрии введен в 28-ю версию Андроид, именно для этой или более высокой версии предназначена компонента. В меньших версиях она загружается, но метод Подключить возвращает Ложь. Использование стандартного диалога гарантирует поддержку других средств аутентификации (например сканера сетчатки или лица), которые появятся в Андроид позже.

Примечание: Начиная с 23й версии, Андроид имеет другой набор классов для использования сканера отпечатка - fingerprint. Он не содержит визуальных элементов, чтобы им воспользоваться, необходимо самостоятельно делать активность (или форму 1С). Автор этой статьи, его клиенты и коллеги уже два года успешно используют компоненту, выполненную на основе этого, ныне устаревшего, механизма.

Примечание: В 15-й версии платформы 1С объявила о внедрении биометрии в мобильной платформе, но мне не удалось найти способы ее использования и узнать "идеологию" работы ни в справочной информации, ни на сайте ИТС. Возможно, я не проявил необходимой настойчивости в поиске.

Компонента реализована как устройство ввода из данного стандарта. Имя объекта - BiometricDialog:

ПодключитьВнешнююКомпоненту("ОбщийМакет.Компонента", "IKSoftWare", ТипВнешнейКомпоненты.Native);
Компонента = Новый("AddIn.IKSoftWare.BiometricDialog");

Она имеет следующие параметры:

  • KeyName - строка без пробелов. Должен быть обязательно установлен. Он определяет имя контейнера ключа. Если Вы зашифровали информацию с определенным именем ключа, для ее расшифровки необходимо использовать точно такое же имя. Конечно же, вы можете использовать сколько угодно ключей.
  • Action - целое число равное 0 для шифрования или 1 для расшифровки
  • Data - данные для шифрования (строка) или для расшифровки
  • DecodeKey - открытый ключ для расшифровки. Параметр необходимо задать, если Action = 1. Он возвращается во внешнем событии после успешного шифрования (см. ниже)
  • DialogTitle - строка-заголовок диалога, необходимо обязательно установить
  • CancelText - текст на кнопке отмены, необходимо обязательно установить
  • DialogSubtitle - строка-подзаголовок диалога
  • DialogDescription - строка описания, отображаемая на диалоге

После подключения и инициализации параметров, необходимо вызвать метод Подключить. Если все условия вывода диалога выполнены (кроме соответствующего релиза ОС необходима регистрация в системе хотя бы одного отпечатка), он вернет Истину и отобразит всплывающий диалог:

Его закрытие вызывает в платформе такие внешние события:

  • DriverError - ошибка драйвера, аргумент события "Данные" содержит текст описания ошибки
  • AuthenticationFailed - ошибка проверки (приложен чужой или другой палец). Данные пустые.
  • AuthenticationHelp - прочие ошибки распознавания, "Данные" содержит текст
  • AuthenticationCanceled - отмена
  • BiometricData - успешное распознавание. Данные содержат строку xml следующей структуры:
<BiometricTouch>
 <Data>...</Data>
 <DecodeKey>...</DecodeKey>
</BiometricTouch>

Тэг Data содержит зашифрованную строку при шифровании или результат расшифровки, а DecodeKey - открытый ключ в кодировке base64.

Компонента предназначена для релиза мобильной платформы 8.3.15.62.

Скачать файлы

Наименование Файл Версия Размер
Компонента аутентификации и шифрования с помощью биометрической информации для Андроид:

.cf 1,57Mb
2
.cf 1.0.1 1,57Mb 2 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. McLer 120 12.11.19 10:06 Сейчас в теме
На iOS нет такой?

Начиная с 23й версии, Андроид имеет другой набор классов для использования сканера отпечатка - fingerprint.

планируете ли обновлять компоненту?
2. IgorKissil 334 13.11.19 08:02 Сейчас в теме
(1)
На iOS нет такой?

На iOS пока нет
(1)
планируете ли обновлять компоненту?

Непонятно про обновление. Если Вы прочитали, компонента, использующая fingerprint у меня есть. Она отдельная с этой никак не связана. Выкладывать в общий доступ не планирую.
4. vsesam80 07.02.20 21:42 Сейчас в теме
(2)
&НаКлиенте 
перем  КлючПароля Экспорт ;
//модуль формы
&НаКлиенте
Процедура Зашифровать(Команда)
    #Если МобильноеПриложениеКлиент Тогда
        ПоддерживаетсяЗащитаДоступа = БезопасноеХранилище.ПоддерживаетсяЗащитаДоступа(СпособЗащитыДоступаБезопасногоХранилища.Нет);
        Если ПоддерживаетсяЗащитаДоступа Тогда
            ОписаниеОповещения = Новый ОписаниеОповещения("ЗавершениеПомещенияБХ", ЭтотОбъект);
            КлючПароля = Строка(Новый УникальныйИдентификатор); // здесь можно любую строку передать
            БезопасноеХранилище.НачатьПомещениеДанных(КлючПароля, "Ключ у прораба!", СпособЗащитыДоступаБезопасногоХранилища.ТребуетсяДополнительнаяПроверкаПользователя,СпособДополнительнойПроверкиПользователя.БиометрическаяИлиВводПароля, ОписаниеОповещения);  
        Иначе
            Сообщить("на вашем устройстве не поддерживается работа безопасного хранилища!");
        КонецЕсли
        #КонецЕсли
КонецПроцедуры
    
&НаКлиенте
Процедура Расшифровать(Команда)
    #Если МобильноеПриложениеКлиент Тогда 
        ОписаниеОповещенияЗавершения = Новый ОписаниеОповещения("ЗавершениеПолученияЗначения", ЭтотОбъект);
        БезопасноеХранилище.НачатьПолучениеДанных(КлючПароля, ОписаниеОповещенияЗавершения); 
    #КонецЕсли
КонецПроцедуры

&НаКлиенте
Процедура ЗавершениеПомещенияБХ(Результат, Ключ, ДополнительныеПараметры) Экспорт
а = 0;
КонецПроцедуры     


&НаКлиенте
Процедура ПолучитьПароль(КлючПароля)
#Если МобильноеПриложениеКлиент Тогда
ОписаниеОповещенияЗавершения = Новый ОписаниеОповещения("ЗавершениеПолученияЗначения", ЭтотОбъект);
БезопасноеХранилище.НачатьПолучениеДанных(КлючПароля, ОписаниеОповещенияЗавершения);  
#КонецЕсли
КонецПроцедуры

&НаКлиенте
Процедура ЗавершениеПолученияЗначения(Результат, Ключ, Значение, ДополнительныеПараметры) Экспорт
а= 0;
Сообщить(Значение);
КонецПроцедуры  

КлючПароля = "555"; 
Показать

Биометрии нет на телефоне, но интересно было бы проверить. А так пинкод работает
В синтаксис помощнике нет описания этой магии. Но, подсказки работают.
3. vsesam80 07.02.20 20:47 Сейчас в теме
В 15-й версии платформы 1С объявила о внедрении биометрии в мобильной платформе, но мне не удалось найти способы ее использования и узнать "идеологию" работы ни в справочной информации, ни на сайте ИТС.

Игорь, вы не про это писали?
&НаКлиенте
Процедура СохранитьПарольВБезопасноеХранилище(ПарольСтрока)
    
    #Если МобильноеПриложениеКлиент Тогда
        ПоддерживаетсяЗащитаДоступа = БезопасноеХранилище.ПоддерживаетсяЗащитаДоступа(СпособЗащитыДоступаБезопасногоХранилища.Нет);
        Если ПоддерживаетсяЗащитаДоступа Тогда
        ОписаниеОповещения = Новый ОписаниеОповещения("ЗавершениеПомещенияБХ", ЭтотОбъект);
        КлючПароля = Строка(Новый УникальныйИдентификатор); // здесь можно любую строку передать
        БезопасноеХранилище.НачатьПомещениеДанных(КлючПароля, ПарольСтрока, СпособЗащитыДоступаБезопасногоХранилища.Нет,, ОписаниеОповещения);    
    #КонецЕсли
    
КонецПроцедуры

&НаКлиенте
Процедура ЗавершениеПомещенияБХ(Результат, Ключ, ДополнительныеПараметры) Экспорт

КонецПроцедуры


ПОЛУЧЕНИЕ:

&НаКлиенте
Процедура ПолучитьПароль(КлючПароля)

ОписаниеОповещенияЗавершения = Новый ОписаниеОповещения("ЗавершениеПолученияЗначения", ЭтотОбъект);
БезопасноеХранилище.НачатьПолучениеДанных(КлючПароля, ОписаниеОповещенияЗавершения);

КонецПроцедуры

&НаКлиенте
Процедура ЗавершениеПолученияЗначения(Результат, Ключ, Значение, ДополнительныеПараметры) Экспорт

КонецПроцедуры
Показать


Если на мобильном устройстве используется биометрическая идентификация пользователя, то узнать, какой способ используется в данный момент, можно с помощью метода ТекущийСпособБиометрическойПроверки(). Результат работы данного метода можно использовать в разных целях, например:

● Для формирования сообщения, которое передается в метод НачатьПроверку().

● Для определения, что надежность используемого способа проверки устраивает разработчика приложения.

В общем случае, пример дополнительной проверки пользователя мобильного приложения может выглядеть следующим образом:

Процедура ПроверитьПользователя()
СпособПроверки = СпособДополнительнойПроверкиПользователя.ТолькоБиометрическая;
Если Не ДополнительнаяПроверкаПользователя.ПоддерживаетсяПроверка(СпособПроверки) Тогда
Возврат;
КонецЕсли;
ТекущаяБиометрия = ДополнительнаяПроверкаПользователя.ТекущийСпособБиометрическойПроверки();
Если ТекущаяБиометрия <> СпособБиометрическойПроверки.РаспознаваниеОтпечаткаПальца Тогда
Возврат;
КонецЕсли;
Сообщение = "Отсканируйте отпечаток пальца";
Обработчик = Новый ОписаниеОповещения();
ДополнительнаяПроверкаПользователя.НачатьПроверку(СпособПроверки, Сообщение, Обработчик);
КонецПроцедуры
Процедура ОбработкаРезультатовПроверки(ОтмененоПользователем, ДополнительныеПараметры) Экспорт
Если Не ОтмененоПользователем Тогда
// пользователь подтвержден
КонецЕсли;
КонецПроцедуры
5. IgorKissil 334 07.02.20 22:02 Сейчас в теме
(3) Похоже - это оно. На момент написания статья последним был 15-й релиз и там описания большинста методов в синтаксис помошнике нет! (Проверил только что) А в 16-м добавили.
6. madonov 156 12.02.20 05:57 Сейчас в теме
(5)
Перепробовал все версии мобильного клиент 8.3.15 - не работает, вылетает клиент без каких-либо ошибок.
Сервер 8.3.15.1778.

Что интересно - конфа сохраняется без ошибок, а вот подсказки через точку при наборе кода нет. Режим совместимости не используется.
7. IgorKissil 334 15.02.20 19:51 Сейчас в теме
(6) Тот же результат. Любое обращение к "ДополнительнаяПроверкаПользователя" приводит к падению приложенния. Мобильная платформа последняя 8.3.15.86. Так что разработка пока актуальна.
8. user1465376 18.09.20 16:30 Сейчас в теме
(3) В коде ошибка
Нужно Обработчик = Новый ОписаниеОповещения("ОбработкаРезультатовПроверки",ЭтаФорма);
Спасибо за код, у меня получилось!
9. user1465376 18.09.20 16:39 Сейчас в теме
(3) В коде ошибка
Нужно Обработчик = Новый ОписаниеОповещения("ОбработкаРезультатовПроверки",ЭтаФорма);
Спасибо за код, у меня получилось !
Оставьте свое сообщение

См. также

Дневник времени. Простое мобильное приложение 1С для телефона на Андроид Промо

Мобильная разработка v8::Mobile Абонемент ($m)

Дневник времени. Для адептов тайм-менеджмента и всех тех, кто ценит свое время. Предназначен для ежедневных записей в телефоне расхода времени на различные задачи. Отчет по записям программы позволяет увидеть, сколько времени, на какие задачи расходовалось и проанализировать траты времени за месяц. Можно выгрузить записи в csv файл и анализировать на дескопном компьютере, например в Экселе. Можно составлять планы на день и отмечать, что удалось сделать, а что нет.

1 стартмани

12.03.2021    3354    4    pricec    1    

Внешняя компонента - универсальный, надежный перехватчик клавиатурных событий

Разработка внешних компонент v8 Абонемент ($m)

Перехват нажатия клавиш в 1С реализован с привязкой к фокусу формы. Если форма (или главное окно процесса 1С) теряет фокус, то перехват перестает работать. Чтобы решить эту проблему, была разработана соответствующая внешняя компонента.

1 стартмани

29.11.2021    2547    7    Prometeus2011    5    

1Scan. Интеграция веб-клиента 1С с устройством Android (смартфон, планшет, ТСД)

Мобильная разработка WEB v8 Абонемент ($m)

Получение из Android устройства данных сканера штрихода, камеры, GPS, широковещательных сообщений и передача в код модуля формы 1С для дальнейшей обработки.

15.11.2021    2159    2    kild    17    

Внешняя компонента для мобильного приложения

Разработка внешних компонент Мобильная разработка v8::Mobile Россия Абонемент ($m)

Внешняя компонента для дополнения мобильной платформы некоторыми функциями.

1 стартмани

02.11.2021    2309    6    Prometeus2011    13    

Внешняя компонента: Android tools Промо

Мобильная разработка Разработка внешних компонент v8 v8::Mobile Абонемент ($m)

Несколько дополнительных функций для мобильного приложения\клиента под Android. Размер архива внешних компонент под архитектуры ARM и x86 - 230KB.

1 стартмани

12.01.2021    7080    23    KAV2    15    

Пример формы авторизации на Javascript для мобильного приложения

Мобильная разработка v8 v8::Mobile 1cv8.cf Абонемент ($m)

Пример формы авторизации на Javascript для мобильного приложения

3 стартмани

25.10.2021    1754    4    rail21    11    

Присоединенная ЭЦП средствами платформы

Защита и шифрование v8 1cv8.cf Абонемент ($m)

Без внешних компонент.

10 стартмани

06.08.2021    3526    9    sivin-alexey    1    

Внешняя компонента для работы по Web-socket протоколу x32 x64 Промо

Разработка внешних компонент WEB v8 Абонемент ($m)

Кто когда-нибудь сталкивался с обменом данными по Web-Socket (wss) протоколу из 1С, тому известно, что в платформе отсутствуют данные механизмы (не путать с HTTP запросами и WebServices). Предлагается использовать внешнюю компоненту, написанную по технологии NativeAPI, для подключения и обмена с серверами из 1С-Предприятия, работающими по протоколу Web-Socket.

2 стартмани

30.03.2018    39072    90    Ditron    114    

Распознавание речи в мобильном приложении 1С на Android

Мобильная разработка Разработка внешних компонент v8::Mobile Абонемент ($m)

Внешняя компонента для мобильной платформы 1С, работающая в связке с отдельной службой и позволяющая реализовать распознавание речи в мобильном приложении на Android.

1 стартмани

15.07.2021    4812    5    salexdv    6    

Мобильное приложение для 1C:Drive для фотоотчетов с сохранением фотографий в Microsoft Azure Blob storage

Мобильная разработка v8::Mobile Абонемент ($m)

Пример реализации мобильного приложения, которое использует Microsoft Azure Blob storage для сохранения фотографий и передает сведения о сделанных фотографиях в 1C:Drive.

1 стартмани

26.02.2021    3860    3    keypax    2    

Авторизация в мобильном приложении 1С

Роли и права Мобильная разработка v8 v8::Mobile 1cv8.cf Абонемент ($m)

Реализация входа по паролю (личному коду) в мобильном приложении 1С.

10 стартмани

23.02.2021    6263    6    kaiman_fedor_yandex    0    

TextRadar - нечеткий поиск в тексте Промо

Разработка внешних компонент Поиск данных v8 1cv8.cf Абонемент ($m)

В отличие от нечеткого сравнения строк, когда обе сравниваемых строки равнозначны, в задаче нечеткого поиска выделяются строка поиска и строка данных, а вычислить необходимо не степень похожести двух строк, а степень присутствия строки поиска в строке данных. Нормированный коэффициент, находящийся между 0 и 1 позволяет отсечь заведомо низкие результаты, организовать поиск по синонимам и т.д. Наглядное отображение результатов в кратком и детальном виде поможет быстро найти интересующий фрагмент.

1 стартмани

19.09.2018    25058    32    TSSV    19    

Криптография (шифрование) на эллиптических кривых

Защита и шифрование v8 1cv8.cf Россия Абонемент ($m)

Тема шифрования сейчас очень популярна, а шифрование на эллиптических кривых является топом, поскольку считается одним из самых надежных криптографических алгоритмов (и поэтому используется в Bitcoin и других криптовалютах, SSL протоколе и т.д.). У меня же возник интерес - а возможно ли реализовать шифрование на эллиптических кривых средствами 1С... и теперь мне известен ответ.

3 стартмани

12.01.2021    6540    4    ikar-nikolay    8    

Выбор документов на мобильном устройстве (iOS)

Мобильная разработка v8::Mobile Абонемент ($m)

При внедрении мобильного приложения, имеющего в своём функционале работу с файлами, возникла необходимость прикреплять к документам не только фотографии из библиотеки мультимедиа или тут же созданные фотографии, а документы (pdf, doc, xlsx, и др.). В операционной системе iOS файловая система скрыта для пользователя и взаимодействие с файлами осуществляется средствами самого приложения и только с файлами, расположенными в директории приложения (контейнере приложения). Т.е. задачей было поместить файлы в директорию приложения и организовать взимодествие с этим каталогом.

1 стартмани

29.11.2020    4116    0    OlegK    0    

Использование сборок .NET в 1С 7. и 8.x. Создание внешних Компонент. Промо

Разработка внешних компонент v7.7 v8 1cv8.cf 1cv7.md Абонемент ($m)

Данная разработка создана для использования сборок .Net в 1С через преобразование объектов и классов в COM-объекты, которые можно использовать в 1С. Достигается это путем создания класса, реализующего методы интерфейса IReflect public class AutoWrap: IReflect.

1 стартмани

28.11.2013    95341    298    Serginio    76    

Подпись данных алгоритмами SHA + AES собственным модулем

Защита и шифрование v8 1cv8.cf Россия Абонемент ($m)

Реализация подписи данных ключом длиной 256 бит алгоритмами SHA-256 + AES-256 без использования внешних компонент, zip-файлов, обращения к диску или БД и без привязки к ОС.

2 стартмани

01.11.2020    5122    5    1div0    8    

Быстрый алгоритм шифрования AES ECB 128/192/256

Защита и шифрование v8 1cv8.cf Россия Абонемент ($m)

Реализация существенно оптимизированного алгоритма симметричного шифрования AES (Advanced Encryption Standard) в режиме ECB (Electronic codebook) с различной длиной ключа 128/192/256 без использования внешних компонент, zip-файлов, обращения к диску или БД и без привязки к ОС.

1 стартмани

30.10.2020    7024    39    1div0    48    

Программа расчёта питательной ценности ежедневной диеты по тридцати восьми нутриентам (мобильное приложение 1С для Андроид), APK + исходная конфигурация

Мобильная разработка v8::Mobile Домашние учет и финансы Абонемент ($m)

Мобильное приложение на платформе 1С с исходной конфигурацией. Пример решения задач по интерфейсу и первичному заполнению базы.

5 стартмани

12.10.2020    4409    1    ovasiliev    4    

Приложение Android для идентификации/распознавания образов (с обучением с одного раза, One-Shot Learning) с возможностью работы с 1С через веб-сервис Промо

Мобильная разработка v8 Абонемент ($m)

В данной статье описано приложение, алгоритм и методика распознавания изображений, предоставляющее посредством http-запросов информацию о распознанных объектах в 1С. В качестве примера интеграции прилагается конфигурация, реализующая веб-сервис для приема запросов от приложения.

1 стартмани

19.06.2018    20672    5    informa1555    16    

Использование встроенного сканера ТСД на Android в мобильном клиенте и мобильном приложении (драйвер сканера Android для 1С)

Разработка внешних компонент Мобильная разработка v8 Абонемент ($m)

Используя данный драйвер, можно без единой строки кода, просто установив на ТСД мобильный клиент 1С, сразу начать подбирать товары в документах вашей учётной системы. А, адаптировав нужные формы под небольшой размер экрана ТСД, можно просто создать полноценное рабочее место для выполнения операций с помощью ТСД, не прибегая к стороннему софту. Если же на складе плохая связь (или её нет вовсе), то можно использовать возможности мобильного клиента в автономном режиме (потребуется доработка вашей конфигурации). Драйвер также можно использовать и для Android приложения на мобильной платформе. В результате чего можно обойтись без ненужных полей ввода и клавиатуры «на пол-экрана».

3 стартмани

09.10.2020    25352    201    ltfriend    153    

Обфускатор операционного кода 1С

Защита и шифрование Защита ПО v8 1cv8.cf Россия Абонемент ($m)

Защита обработок 1С от восстановления исходного кода awa-ким декомпилятором. Протестировано 1С:Предприятие 8.3 (8.3.16.1502)

3 стартмани

18.09.2020    10500    53    MoiseevSN    58    

1C.QuickPhoto - мобильное приложение для быстрой отправки фотографий в присоединенные файлы БСП

Мобильная разработка Обработка справочников Адаптация типовых решений v8 УНФ ERP2 УТ11 КА2 Абонемент ($m)

Приложение предназначено для быстрого прекрепления фотографий к документам и справочникам программ 1С. Требуется установить расширение для своей конфигурации и опубликовать http-сервис.

2 стартмани

17.09.2020    6072    13    suepifanov    34    

Tool1CD Beta в деле Промо

Разработка внешних компонент v8 Абонемент ($m)

Пс, парень! Не хочешь немного сырых байтов?

1 стартмани

09.05.2018    33045    32    dmpas    26    

Мобильная платформа. Штрихкоды в Android.

Разработка внешних компонент Мобильная разработка Сканер штрих-кода v8::Mobile Абонемент ($m)

Пример конфигурации, содержащей внешнюю компоненту для мобильной платформы, выводящую изображение штрихкода в интерфейсе мобильного приложения.

3 стартмани

14.09.2020    5316    4    kinan    19    

Инструменты отладки Web-страниц в приложении на устройстве Android

Прочие инструменты разработчика Разработка внешних компонент WEB v8::Mobile Абонемент ($m)

При разработке сложных интерфейсов на базе HTML часто возникает необходимость отладки стилей CSS и скриптов непосредственно на устройстве. Статья описывает способ отладки web-содержимого приложения мобильной платформы 1С на Андроид устройстве с помощью Chrome Development Tools.

7 стартмани

26.08.2020    6890    5    ingeneerz@gmail.com    2    

Мусорная корзина, или удаление помеченных объектов для мобильной платформы

Мобильная разработка Чистка данных v8 v8::Mobile 1cv8.cf Абонемент ($m)

Обработка удаления помеченных объектов для встраивания в Ваши мобильные приложения.

2 стартмани

18.08.2020    4654    3    GAMLET    0    

Мобильное приложение "Отчет по проделанной работе" Промо

Мобильная разработка Учет рабочего времени Учет рабочего времени v8 Россия УУ Абонемент ($m)

Приложение выполняет фиксацию рабочего времени у клиентов, а также заявок на работы, пригодится как шаблон для разработки своего или как готовое решение для работников в сфере услуг, которые фиксируют время у клиентов. В приложении 2 документа: первый "отчет за день", второй "заявка" и полезный инструмент "Отчет задачи", который в свою очередь создан для просмотра, анализа и закрытия заявок. Тестировал на Iphone 6s.

10 стартмани

01.12.2017    29787    10    olejnikov_m    6    

Расширение "PUSH уведомления для мобильного клиента".

Мобильная разработка v8::Mobile КА1 ERP2 УТ11 1С:CRM Россия Абонемент ($m)

Расширение для отправки PUSH уведомлений в мобильный клиент на Android. Подходит для типовых конфигураций, протестирована на конфигурации КА 2.4.

1 стартмани

04.08.2020    6862    11    romanpolyashov@yandex.ru    0    

Диагностика контекста выполнения (внешняя компонента)

Разработка внешних компонент v8 1cv8.cf Абонемент ($m)

Небольшая экспериментальная внешняя компонента для получения дополнительной информации о контексте выполнения.

1 стартмани

24.07.2020    9659    2    YPermitin    14    

Нано HTTP сервер - внешняя компонента для мобильного приложения 1C, на Android

Разработка внешних компонент Мобильная разработка v8 v8::Mobile 1cv8.cf Абонемент ($m)

Нано HTTP сервер на терминале сбора данных "ATOL Smart.Lite android 7.0". Работает только с GET и POST запросами. Аутентификация BASE64. Не поддерживает HTTPS и не передает файлы. В прикрепленном архиве исходники на компоненту (С++ и java для Android Studio 3.6.2), ЦФ - мобильного приложения и тестовая обработка.

1 стартмани

22.06.2020    7688    13    SanyMaga    19    

NativeDraw: Компонента рисования для 1С [V2.6.2] Промо

Разработка внешних компонент Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Рисуйте в формах 1С, также предлагается небольшое количество нерисовальных функций

1 стартмани

13.07.2015    54620    474    ПерваяСистема    147    

Перехват сканирования Android Native API

Разработка внешних компонент Мобильная разработка v8::Mobile Абонемент ($m)

Native компонента для перехвата сканирования шк и передачу в мобильную 1С.

1 стартмани

29.04.2020    12014    67    evgeny43    57    

Мобильная платформа. Уникальный идентификатор устройства Android при помощи внешней компоненты. Не IMEI

Разработка внешних компонент Мобильная разработка v8::Mobile Абонемент ($m)

Идентифицируем устройства, на которых установлены копии нашего приложения.

3 стартмани

23.04.2020    8201    8    kinan    19    

Внешняя компонента Native API для управления окнами и буфером обмена, получения снимков окон Windows и Linux

Разработка внешних компонент v8::УФ Россия Абонемент ($m)

Внешняя компонента Native API для Windows и Linux с исходными кодами на C++. Возможности компоненты: получение списка окон и списка процессов, управление размерами и положением окна, снимок окон и снимок экрана, доступ к данным буфера обмена, взаимодействие по протоколу WebSocket.

2 стартмани

16.04.2020    8069    14    kandr    13    

Компоненты распознавания и печати штрих-кодов Промо

Разработка внешних компонент Сканер штрих-кода v7.7 v8 1cv8.cf 1cv7.md Абонемент ($m)

Комплект программного обеспечения для реализации функций оптического распознавания штрих-кодов различных систем при помощи обычной web-камеры, а также их отображения в печатных формах. Программы могут работать в составе конфигураций, созданных на базе платформ «1С-Предприятие» версий 7.7, 8.2, 8.3. Компонент чтения кодов реализован в виде внешней компоненты 1С с COM-интерфейсом. Компонент отображения создан по стандартной технологии ActiveX для Windows, и может быть встроен в любое приложение, поддерживающее встраивание ActiveX элементов управления, например в документ Word или Excel, или форму VBA. P.S. Добавлена новая версия программы распознавания. Новые функции: обработка видео в реальном режиме (а не по таймеру, как раньше), добавлена возможность распознавания штрих-кодов из графических файлов JPEG, PNG, GIF, BMP, а также передавать для распознавания картинки из 1С, теперь можно получить в 1С захваченное с камеры или файла изображение, как с выделением мест, содержащих коды, так и без, а также отдельные фрагменты изображений, содержащие код. Добавлены новые свойства и методы для программирования. Обновлена документация.

10 стартмани

10.07.2015    78820    91    igorberezhnov    121    

Мобильная платформа. Шифрование строк в Android при помощи внешней компоненты

Разработка внешних компонент Защита и шифрование v8::Mobile Молдова Абонемент ($m)

Внешняя компонента для мобильной платформы на Android. Шифруем строки.

3 стартмани

15.04.2020    6149    1    kinan    0    

Android Java и NativAPI C++ внешняя компонента для широковещательных сообщений (отправка и прием). Подключаем сканер ШК и клавиатуру к "1С мобильное приложение"

Оптовая торговля Розничная торговля Сканер штрих-кода Разработка внешних компонент Мобильная разработка v8::Mobile Оптовая торговля, дистрибуция, логистика Абонемент ($m)

Подключаем сканер ШК и клавиатуру к "1С мобильное приложение", на терминале сбора данных "ATOL Smart.Lite android 7.0". Работаем с буфером обмена. В архиве к теме; 1. исходник компоненты (папка package готовый zip); 2. исходник "AccessibilityService" для перехвата клавиатуры (папка package готовый apk); 3. cf - тестовая конфигурация

1 стартмани

15.04.2020    11059    74    SanyMaga    88    

Мобильная платформа. Реакция на внешнее событие в Android при помощи внешней компоненты

Мобильная разработка Разработка внешних компонент v8::Mobile Молдова Абонемент ($m)

Внешняя компонента для мобильной платформы на Android. Пришиваем платформе уши, чтобы лучше слышать.

3 стартмани

06.04.2020    9527    17    kinan    25    

Полезные приемы при работе с Excel из 1С (Версия 3.1) Промо

Разработка внешних компонент Загрузка и выгрузка в Excel Практика программирования v8 1cv8.cf Абонемент ($m)

Программисту 1С часто приходится работать с таблицами Excel из 1С. Я постарался собрать небольшой FAQ и набор функций для работы с файлами Excel. Надеюсь, кому-то будет полезна данная статья.

1 стартмани

22.09.2015    261990    526    Zerocl    85    

Получение фото с веб-камеры

Разработка внешних компонент v8 Абонемент ($m)

Получение фото с веб-камеры без ActiveX. Внешняя компонента по технологии Native API.

1 стартмани

25.03.2020    12878    109    berezdetsky    46    

Готовые решения для инвентаризации товаров и основных средств на мобильных устройствах для КА, УТ, ERP и БП 3.0 на базе Simple UI

Оптовая торговля Розничная торговля Учет ОС и НМА Мобильная разработка Склад и ТМЦ v8 ERP2 БП3.0 УТ11 КА2 БУ УУ Абонемент ($m)

В расширениях для Бухгалтерия 3.0 и КА2.4/УТ11.4/ERP2.4 представлены готовые рабочие места для онлайн и оффлайн инвентаризации товаров (для БП 3.0 также инвентаризации основных средств) на базе бесплатного конструктора мобильного фронта Simple UI. При этом используется расширенная работа с идентификацией товаров и ОС с помощью различных подходов – сканирование штрих кода, распознавание артикулов и инвентарных номеров и различные поиски. Также используются различные возможности платформы Simple UI. Данная разработка может быть полезна как конечным пользователям, так и разработчикам в качестве заготовки, так как на базе этих блоков можно сделать ввод любого документа конфигурации , связанного с товаром или с ОС. Тестировалось на 1С 8.3.13.1865, КА 2.4.8.63 и БП 3.0.74.69

5 стартмани

28.02.2020    16873    76    informa1555    76    

Обработка голосового ввода текста с использованием (intent)

Мобильная разработка v8::Mobile 1cv8.cf Абонемент ($m)

Обработка для голосового ввода текста с использованием дополнительных возможностей ОС Android.

1 стартмани

26.02.2020    6339    4    algabas    7    

7 причин, почему интеграция стала приятной. Не упускайте ряд потрясающих возможностей Промо

Внешние источники данных Интеграция с сервисами Мобильная разработка v8 1cv8.cf Абонемент ($m)

В статье показаны примеры получения данных без программирования на стороне «1С:Предприятие 8». Вам нужно проверить гипотезу и проанализировать данные, почему бы не интегрироваться с Excel? Используете технологии .NET и «1С:Предприятие 8», процесс связывания систем движется катастрофически медленно? Хотите native Android приложение с вашими данными всегда под рукой?

1 стартмани

01.10.2015    63766    51    pbazeliuk    23    

Быстрая печать этикеток (ZPL, EPL, TSPL, EZPL, GEPL, TSPL-EZ)

Разработка внешних компонент v8 v8::УФ 1cv8.cf Абонемент ($m)

Качественная и быстрая печать на внутреннем языке принтеров этикеток.

4 стартмани

02.02.2020    14847    60    Johny_v    16    

Сканирование по TWAIN в 1С (обычные и управляемые формы)

Разработка внешних компонент v8 v8::УФ 1cv8.cf Абонемент ($m)

Обработка показывает пример, как можно в 1С проводить сканирование с помощью компоненты TWAIN.

3 стартмани

03.01.2020    10706    36    Denr83    0    

Обмен данными с Android через USB

Мобильная разработка Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Обработка с примером обмена данными конфигурации 1С через USB. Без установки Web сервера и настройки WiFi.

1 стартмани

23.12.2019    7719    7    asdfgcom    2    

Давайте подружим 1С и Android. Часть 1 - постановка задачи и подход к решению Промо

Мобильная разработка v8 Абонемент ($m)

Серия уроков по созданию простейшего приложения на платформе Android для взаимодействия с 1С.

1 стартмани

29.02.2016    36221    42    solarisman    32    

Simple UI: простой конструктор мобильных приложений для устройств на Android. Обновление от 25.12.21 - большой пак полезностей

Мобильная разработка v8 УУ Абонемент ($m)

Simple UI – это полностью бесплатная платформа для создания мобильных рабочих мест на Android. Конструктор позволяет создавать мобильные клиенты для учетных систем и самостоятельные приложения на телефонах, ТСД (терминалах сбора данных), планшетах, электронных киосках и других устройствах. При этом не нужно разбираться в мобильной разработке, Android SDK ведь основная цель платформы – максимально упростить процесс разработки и поддержки, сделать его визуальным, собирать приложения из готовых блоков с минимумом кода. Причем код обработчиков можно писать на языке учетной системы либо задавать логику обработки событий с помощью команд REST, SQL и визуального конструктора. Проект постоянно развивается изыскивая новые способы упрощения разработки и повышения функционала и является пожалуй самым быстрым способом как создать MVP-проект так и продакшн-систему под конкретное внедрение или тиражный продукт.Тестировалось на 1С: Предприятие 8.3 релиз 8.3.13.1865.

1 стартмани

14.11.2019    33880    347    informa1555    213    

Получение AndroidID в мобильном приложении

Мобильная разработка v8::Mobile Россия Абонемент ($m)

Получаем Android DeviceID в мобильном приложении/клиенте, используя стороннее приложение.

1 стартмани

05.11.2019    12519    8    sam441    13