Выгрузка работников из Бухгалтерии в Документооборот КОРП

Публикация № 1128232

Управление - Документооборот и делопроизводство

документооборот веб-сервис пользователь синхронизация

Описание реализации выгрузки пользователей из конфигурации Бухгалтерия для Казахстана (ред. 1) в Документооборот для Казахстана КОРП (ред. 2). На стороне источника используется веб-сервис. На стороне приемника внешняя обработка.

На стороне источника (БП) реализован веб-сервис UploadUsers и метод Upload().

Для передачи данных реализован XDTO-пакет следующей структуры:

Написана функция для метода Upload(). Код приведен ниже:

Функция Upload()
	
	УстановитьПривилегированныйРежим(Истина);
	
	Запрос = Новый Запрос;
	Запрос.Текст=
	"ВЫБРАТЬ РАЗРЕШЕННЫЕ
	|	РаботникиОрганизацийСрезПоследних.Физлицо,
	|	МАКСИМУМ(РаботникиОрганизацийСрезПоследних.Период) КАК Период,
	|	РаботникиОрганизацийСрезПоследних.ПричинаИзмененияСостояния,
	|	РаботникиОрганизацийСрезПоследних.ПодразделениеОрганизации,
	|	РаботникиОрганизацийСрезПоследних.Должность
	|ПОМЕСТИТЬ втПриемы
	|ИЗ
	|	РегистрСведений.РаботникиОрганизаций.СрезПоследних(
	|			&ДатаАктуальности,
	|			Организация = &Организация
	|				И ПричинаИзмененияСостояния В (&сзСостояния)) КАК РаботникиОрганизацийСрезПоследних
	|
	|СГРУППИРОВАТЬ ПО
	|	РаботникиОрганизацийСрезПоследних.Физлицо,
	|	РаботникиОрганизацийСрезПоследних.ПричинаИзмененияСостояния,
	|	РаботникиОрганизацийСрезПоследних.ПодразделениеОрганизации,
	|	РаботникиОрганизацийСрезПоследних.Должность
	|;
	|
	|////////////////////////////////////////////////////////////////////////////////
	|ВЫБРАТЬ РАЗРЕШЕННЫЕ
	|	РаботникиОрганизацийСрезПоследних.Физлицо,
	|	МАКСИМУМ(РаботникиОрганизацийСрезПоследних.Период) КАК Период,
	|	РаботникиОрганизацийСрезПоследних.ПричинаИзмененияСостояния
	|ПОМЕСТИТЬ втУволенные
	|ИЗ
	|	РегистрСведений.РаботникиОрганизаций.СрезПоследних(
	|			&ДатаАктуальности,
	|			Организация = &Организация
	|				И ПричинаИзмененияСостояния = &парамУвольнение) КАК РаботникиОрганизацийСрезПоследних
	|
	|СГРУППИРОВАТЬ ПО
	|	РаботникиОрганизацийСрезПоследних.Физлицо,
	|	РаботникиОрганизацийСрезПоследних.ПричинаИзмененияСостояния
	|;
	|
	|////////////////////////////////////////////////////////////////////////////////
	|ВЫБРАТЬ РАЗРЕШЕННЫЕ
	|	втПриемы.Физлицо,
	|	втПриемы.ПричинаИзмененияСостояния КАК Принят,
	|	втУволенные.ПричинаИзмененияСостояния КАК Уволен,
	|	втПриемы.ПодразделениеОрганизации,
	|	втПриемы.Должность
	|ПОМЕСТИТЬ втПредРаботники
	|ИЗ
	|	втПриемы КАК втПриемы
	|		ЛЕВОЕ СОЕДИНЕНИЕ втУволенные КАК втУволенные
	|		ПО втПриемы.Физлицо = втУволенные.Физлицо
	|			И втПриемы.Период < втУволенные.Период
	|;
	|
	|////////////////////////////////////////////////////////////////////////////////
	|ВЫБРАТЬ РАЗРЕШЕННЫЕ
	|	втПредРаботники.Физлицо,
	|	втПредРаботники.ПодразделениеОрганизации,
	|	втПредРаботники.Должность
	|ПОМЕСТИТЬ втРаботающие
	|ИЗ
	|	втПредРаботники КАК втПредРаботники
	|ГДЕ
	|	втПредРаботники.Уволен ЕСТЬ NULL
	|;
	|
	|////////////////////////////////////////////////////////////////////////////////
	|ВЫБРАТЬ
	|	КонтактнаяИнформация.Объект,
	|	КонтактнаяИнформация.Тип,
	|	КонтактнаяИнформация.Вид,
	|	КонтактнаяИнформация.Представление
	|ПОМЕСТИТЬ втДоменныеУчетныеЗаписи
	|ИЗ
	|	РегистрСведений.КонтактнаяИнформация КАК КонтактнаяИнформация
	|ГДЕ
	|	КонтактнаяИнформация.Тип = &Тип
	|	И КонтактнаяИнформация.Вид = &Вид
	|;
	|
	|////////////////////////////////////////////////////////////////////////////////
	|ВЫБРАТЬ РАЗРЕШЕННЫЕ
	|	втРаботающие.Физлицо,
	|	втРаботающие.ПодразделениеОрганизации,
	|	ЕСТЬNULL(втРаботающие.Должность, """") КАК Должность,
	|	ЕСТЬNULL(втРаботающие.ПодразделениеОрганизации.Родитель, """") КАК ПодразделениеОрганизацииРодитель,
	|	ЕСТЬNULL(втДоменныеУчетныеЗаписи.Представление, """") КАК ДомменнаяУчетнаяЗапись
	|ИЗ
	|	втРаботающие КАК втРаботающие
	|		ЛЕВОЕ СОЕДИНЕНИЕ втДоменныеУчетныеЗаписи КАК втДоменныеУчетныеЗаписи
	|		ПО втРаботающие.Физлицо = втДоменныеУчетныеЗаписи.Объект
	|
	|УПОРЯДОЧИТЬ ПО
	|	втРаботающие.Физлицо.Наименование";
	Запрос.УстановитьПараметр("Организация", Справочники.Организации.НайтиПоКоду("000000001"));
	Запрос.УстановитьПараметр("ДатаАктуальности", ТекущаяДата());
	Запрос.УстановитьПараметр("Тип", Перечисления.ТипыКонтактнойИнформации.Другое);
	Запрос.УстановитьПараметр("Вид", Справочники.ВидыКонтактнойИнформации.НайтиПоКоду("KR0000007"));

	
	сзСостояния = Новый СписокЗначений;
	сзСостояния.Добавить(Перечисления.ПричиныИзмененияСостояния.ПриемНаРаботу);
	сзСостояния.Добавить(Перечисления.ПричиныИзмененияСостояния.Перемещение);
	
	Запрос.УстановитьПараметр("сзСостояния", сзСостояния);
	Запрос.УстановитьПараметр("парамУвольнение", Перечисления.ПричиныИзмененияСостояния.Увольнение);
	
	тзРез = Запрос.Выполнить().Выгрузить();
	
	Если тзРез.Количество()>0 тогда
		
		МассивПользователейТип = ФабрикаXDTO.Тип("http://www.company.kz/ws/users", "UserList");
		ПользовательТип = ФабрикаXDTO.Тип("http://www.company.kz/ws/users", "User");
		
		UserList = ФабрикаXDTO.Создать(МассивПользователейТип);
		
		Для каждого стр из тзРез Цикл
			
			User = ФабрикаXDTO.Создать(ПользовательТип);
			
			User.FIO         = стр.ФизЛицо.Наименование;
			User.unit_name   = стр.ПодразделениеОрганизации.Наименование;
			User.unit_id     = стр.ПодразделениеОрганизации.Код;
			User.upunit_name = стр.ПодразделениеОрганизацииРодитель.Наименование;
			User.upunit_id   = стр.ПодразделениеОрганизацииРодитель.Код;
			User.user_id     = стр.ФизЛицо.Код; 
			User.user_post   = стр.Должность.Наименование;
			User.dclogin     = стр.ДомменнаяУчетнаяЗапись;
			
			UserList.User.Добавить(User);
			
		КонецЦикла;
		
		Возврат UserList;		
		
	КонецЕсли;
	
	УстановитьПривилегированныйРежим(Ложь);
	
КонецФункции

 

На стороне приемника (ДО) запускается внешняя обработка, которая получает данные от веб-сервиса и создает в ДО подразделения, пользователи, должности. Код обработки приведен ниже:


&НаСервере
Процедура НачатьСинхронизациюНаСервере()
	//подключаемся к веб-сервису
	всОпред = Новый WSОпределения(Объект.СтрокаПодключенияКВебСервису,Объект.Пользователь,Объект.Пароль,,,);
	всПрокси = Новый WSПрокси(всОпред, "http://www.company.kz/ws/users", "UploadUsers", "UploadUsersSoap",,,);
	всПрокси.Пользователь=Объект.Пользователь;
	всПрокси.Пароль=Объект.Пароль;
	//вызываем метод веб-сервиса
	Значение = всПрокси.Upload();
	//создаем таблицу значений, в которую выгрузим данные
	ТЗПользователей = Новый ТаблицаЗначений;
	ТЗПользователей.Колонки.Добавить("ФИО");
	ТЗПользователей.Колонки.Добавить("ДоменнаяУчетнаяЗапись");
	ТЗПользователей.Колонки.Добавить("Подразделение");
	ТЗПользователей.Колонки.Добавить("ВышестоящееПодразделение");
	ТЗПользователей.Колонки.Добавить("Должность");
	ТЗПользователей.Колонки.Добавить("КодСотрудника");
	ТЗПользователей.Колонки.Добавить("КодПодразделения");
	ТЗПользователей.Колонки.Добавить("КодВышестоящееПодразделение");
	
	Для каждого стр из Значение.User цикл
		
		НоваяСтрока = ТЗПользователей.Добавить();
		НоваяСтрока.ФИО                          = стр.FIO;
		НоваяСтрока.ДоменнаяУчетнаяЗапись        = стр.dclogin;
		НоваяСтрока.Подразделение                = стр.unit_name;
		НоваяСтрока.ВышестоящееПодразделение     = стр.upunit_name;
		НоваяСтрока.Должность                    = стр.user_post;
		НоваяСтрока.КодСотрудника                = стр.user_id;
		НоваяСтрока.КодПодразделения             = стр.unit_id;
		НоваяСтрока.КодВышестоящееПодразделение  = стр.upunit_id;
		
	КонецЦикла;
	
	Для каждого стрТЗ из ТЗПользователей цикл
		//ищем подразделение вместе с вышестоящим
		ИскПодразделение = НайтиИлиСоздатьПодразделение(стрТЗ.КодПодразделения,стрТЗ.Подразделение,стрТЗ.КодВышестоящееПодразделение,стрТЗ.ВышестоящееПодразделение);
		//ищем пользователя
		ИскСотрудник = НайтиПользователя(стрТЗ.КодСотрудника);
		
		Если ИскСотрудник=Неопределено тогда
			ОбъектПользователь = Справочники.Пользователи.СоздатьЭлемент();
			//заполняем дополнительный реквизит "КодСотрудника" кодом из источника
			НовСтрока = ОбъектПользователь.ДополнительныеРеквизиты.Добавить();
			НовСтрока.Свойство = ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("КодСотрудника");
			НовСтрока.Значение = стрТЗ.КодСотрудника;
			НовСтрока.ТекстоваяСтрока = стрТЗ.КодСотрудника;

		Иначе ОбъектПользователь = ИскСотрудник.ПолучитьОбъект();	
		КонецЕсли;
		
		ОбъектПользователь.Наименование = стрТЗ.ФИО;
		ОбъектПользователь.Подразделение = ИскПодразделение.Ссылка;
		ОбъектПользователь.КодЯзыка = "ru";
		ОбъектПользователь.ПредставлениеВДокументах = стрТЗ.ФИО;
		ОбъектПользователь.ПредставлениеВПереписке = стрТЗ.ФИО;
		ОбъектПользователь.ПредставлениеВПерепискеСРангом = стрТЗ.ФИО;
		
		//создаем пользователя информационной базы отправляя структуру параметров через дополнительные свойства
		//процедуры сами сделают связь с элементом справочника "Пользователи" и пользователем ИБ через уникальный идентификатор
		ОписаниеПользователяИБ = Новый Структура; 
		ОписаниеПользователяИБ.Вставить("Действие", "Записать"); 
		ОписаниеПользователяИБ.Вставить("Имя", стрТЗ.ФИО);
		ОписаниеПользователяИБ.Вставить("ПолноеИмя", стрТЗ.ФИО);
		ОписаниеПользователяИБ.Вставить("АутентификацияОС", Истина); 
		ОписаниеПользователяИБ.Вставить("ПоказыватьВСпискеВыбора", Истина); 
		ОписаниеПользователяИБ.Вставить("ПользовательОС", стрТЗ.ДоменнаяУчетнаяЗапись); 
		ОписаниеПользователяИБ.Вставить("АутентификацияСтандартная", Ложь); 

		ОбъектПользователь.ДополнительныеСвойства.Вставить("ОписаниеПользователяИБ", ОписаниеПользователяИБ); 
		ОбъектПользователь.Записать();
		//записываем доп сведения по пользователю, чтобы в карточке пользователя отображались
		НаборЗаписей = РегистрыСведений.СведенияОПользователяхДокументооборот.СоздатьНаборЗаписей();
		НаборЗаписей.Отбор.Пользователь.Установить(ОбъектПользователь.Ссылка);
		НаборЗаписей.Прочитать();
		НаборЗаписей.Записать();
		Запись = НаборЗаписей.Добавить();
		Запись.Пользователь = ОбъектПользователь.Ссылка;
		Запись.Подразделение = ИскПодразделение.Ссылка;
		Запись.Должность = ?(ПустаяСтрока(стрТЗ.Должность),"", НайтиИлиСоздатьДолжность(стрТЗ.Должность));
		Запись.ГрафикРаботы = Справочники.ГрафикиРаботы.НайтиПоНаименованию("Пятидневка");
		НаборЗаписей.Записать();		
		
	КонецЦикла;
		
КонецПроцедуры

&НаСервере
Функция НайтиИлиСоздатьДолжность(НаименованиеДолжности)
	
	ИскДолжность = Справочники.Должности.НайтиПоНаименованию(НаименованиеДолжности, Истина);
	
	Если ИскДолжность=Справочники.Должности.ПустаяСсылка() тогда
		ДолжноситьОбъект = Справочники.Должности.СоздатьЭлемент();
		ДолжноситьОбъект.Наименование = НаименованиеДолжности;
		ДолжноситьОбъект.Записать();
		
		ИскДолжносить = ДолжноситьОбъект.Ссылка;
	КонецЕсли;
	
	Возврат ИскДолжность.Ссылка;  	
	
КонецФункции


&НаСервере
Функция НайтиИлиСоздатьПодразделение(КодПодразделения,Подразделение,КодВышестоящееПодразделение,ВышестоящееПодразделение)

	//сперва изем вышестоящее подразделение, если нет то создаем
	Запрос = новый Запрос;
	Запрос.Текст=
	"ВЫБРАТЬ
	|	СтруктураПредприятияДополнительныеРеквизиты.Ссылка
	|ИЗ
	|	Справочник.СтруктураПредприятия.ДополнительныеРеквизиты КАК СтруктураПредприятияДополнительныеРеквизиты
	|ГДЕ
	|	СтруктураПредприятияДополнительныеРеквизиты.Свойство = &Свойство
	|	И СтруктураПредприятияДополнительныеРеквизиты.Значение = &Значение";
	Запрос.УстановитьПараметр("Свойство", ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("ВнешнийКод"));
	Запрос.УстановитьПараметр("Значение", КодВышестоящееПодразделение);	
	
	тзВышПод = Запрос.Выполнить().Выгрузить();
	
	Если тзВышПод.Количество()>0 тогда
		ВышПод = тзВышПод[0].Ссылка.ПолучитьОбъект();
	Иначе ВышПод = Справочники.СтруктураПредприятия.СоздатьЭлемент();	
	    ВышПод.Наименование = ВышестоящееПодразделение;	
		
		НовСтрока = ВышПод.ДополнительныеРеквизиты.Добавить();
		НовСтрока.Свойство = ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("ВнешнийКод");
		НовСтрока.Значение = КодВышестоящееПодразделение;
		НовСтрока.ТекстоваяСтрока = КодВышестоящееПодразделение;
		ВышПод.Записать();

	КонецЕсли;
		
	//теперь ищем само подразделение
	Запрос = новый Запрос;
	Запрос.Текст=
	"ВЫБРАТЬ
	|	СтруктураПредприятияДополнительныеРеквизиты.Ссылка
	|ИЗ
	|	Справочник.СтруктураПредприятия.ДополнительныеРеквизиты КАК СтруктураПредприятияДополнительныеРеквизиты
	|ГДЕ
	|	СтруктураПредприятияДополнительныеРеквизиты.Свойство = &Свойство
	|	И СтруктураПредприятияДополнительныеРеквизиты.Значение = &Значение";
	Запрос.УстановитьПараметр("Свойство", ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("ВнешнийКод"));
	Запрос.УстановитьПараметр("Значение", КодПодразделения);	
	
	тзПод = Запрос.Выполнить().Выгрузить();
	
	Если тзПод.Количество()>0 тогда
		Под = тзПод[0].Ссылка.ПолучитьОбъект();
	Иначе Под = Справочники.СтруктураПредприятия.СоздатьЭлемент();	
	    Под.Наименование = Подразделение;
		
		НовСтрока = Под.ДополнительныеРеквизиты.Добавить();
		НовСтрока.Свойство = ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("ВнешнийКод");
		НовСтрока.Значение = КодПодразделения;
		НовСтрока.ТекстоваяСтрока = КодПодразделения;
		Под.Записать();

	КонецЕсли;
	
	Под.Родитель = ВышПод.Ссылка;
	
	Под.Записать();
	
	Возврат Под.Ссылка;	
	
КонецФункции

&НаСервере
Функция НайтиПользователя(КодСотрудника)
	
	ИскПользователь = Неопределено;
	
	Запрос = Новый Запрос;
	Запрос.Текст=
	"ВЫБРАТЬ
	|	ПользователиДополнительныеРеквизиты.Ссылка
	|ИЗ
	|	Справочник.Пользователи.ДополнительныеРеквизиты КАК ПользователиДополнительныеРеквизиты
	|ГДЕ
	|	ПользователиДополнительныеРеквизиты.Свойство = &Свойство
	|	И ПользователиДополнительныеРеквизиты.Значение = &Значение";
	Запрос.УстановитьПараметр("Свойство",ПланыВидовХарактеристик.ДополнительныеРеквизитыИСведения.НайтиПоНаименованию("КодСотрудника"));
	Запрос.УстановитьПараметр("Значение",КодСотрудника);
	
	тзРез = Запрос.Выполнить().Выгрузить();
	
	Если тзРез.Количество()>0 тогда
		ИскПользователь = тзРез[0].Ссылка;
	КонецЕсли;
	
	Возврат ИскПользователь; 	
	
КонецФункции


&НаКлиенте
Процедура НачатьСинхронизацию(Команда)
	НачатьСинхронизациюНаСервере();
КонецПроцедуры

Можете скачать архив со схемой XDTO-пакета и обработкой "Синхронизация пользователей".

В итоге получаем выстроенную структуру предприятия, пользователей и авторизацию через ОС. Затем, опубликовав базу Документооборот на веб-сервере, получаем работающую систему ДО.

 

Скачать файлы

Наименование Файл Версия Размер
Выгрузка работников из Бухгалтерии в Документооборот КОРП:
.7z 6,45Kb
27.09.19
0
.7z 6,45Kb Скачать

Специальные предложения

Оставьте свое сообщение

См. также

Универсальная выгрузка/загрузка данных для отличающихся конфигураций (JSON, Такси+ОФ) Промо

Перенос данных из 1C8 в 1C8 Универсальные обработки Распределенная БД (УРИБ, УРБД) v8 1cv8.cf Абонемент ($m)

Простой перенос через JSON данных между двумя базами 1С (документов, справочников, ПВХ, ПВР, счетов). Аналогична произвольной выгрузке в типовой "Выгрузка/загрузка XML", но может использоваться для отличающихся конфигураций. Подходит для любых пар баз с любым интерфейсом (управляемый + обычный). Без настроек. Не требует идентичности конфигураций и платформ. При переносе типы данных сопоставляются по наименованиям метаданных, объекты и ссылки по UID.

1 стартмани

22.10.2014    199639    3054    ekaruk    178    

Конвертация данных 2. Использование исходящих и входящих данных. Свойство "Получить из входящих данных"

Обмен данными 1С Перенос данных из 1C8 в 1C8 v8 КД Абонемент ($m)

Разработка правил обмена с использованием исходящих и входящих данных. В качестве примера рассмотрена реальная задача конвертации номенклатуры через регистр сопоставления номенклатур. Статья предназначена в первую очередь для тех, кто только начинает осваивать Конвертацию данных.

17.02.2020    7747    0    Drivingblind    24    

Универсальный обмен данными между идентичными конфигурациями, версия 2020.3.1

Перенос данных из 1C8 в 1C8 v8 1cv8.cf Абонемент ($m)

Обработка «Универсальная выгрузка и загрузка» предназначена для оперативного переноса объектов между двумя идентичными или похожими конфигурациями. Быстрая, надежная и очень простая в использовании обработка.

1 стартмани

29.01.2020    6076    96    vladnet    22    

Помощник подготовки данных для СЗВ-ТД

Зарплата Обработка документов Документооборот и делопроизводство v8 v8::СПР ЗКГУ3.0 ЗУП3.x Россия БУ ФОМС, ПФ, ФСС Абонемент ($m)

С 1 января 2020 г. начался переход на электронные трудовые книжки. Работодателям в 2020 г. предстоит выполнить ряд мероприятий для перехода на ЭТК, а также ежемесячно отчитываться в ПФР обо всех кадровых изменениях по форме СЗВ-ТД. В этой публикации размещена обработка, которая поможет быстро подготовить кадровые документы для заполнения СЗВ-ТД в программе 1С ЗУП 3.1, 1С ЗКГУ 3.1.

1 стартмани

23.01.2020    6853    103    Kaval88    60    

Перенос объектов 1С Промо

Перенос данных из 1C8 в 1C8 v8 v8::УФ 1cv8.cf Абонемент ($m)

Простой и наглядный перенос объектов между любыми базами 1С 8 с предварительным анализом на возможные различия в данных (через файл, через интернет, через буфер обмена). Интерактивная настройка правил обмена на стороне источника и получателя. В обработке есть удобный обзор по подсистемам, поиск и обработка данных по заданному фильтру. Сравнение объектов, поиск ссылок. Конструктор кода по созданию объектов, написание скриптов и отладка мини-функций в УФ. Отключение/включение регламентных заданий. Регистрация/снятие с регистрации объектов в планах обмена. И многое другое. Инструменты администратора в одной обработке.

1 стартмани

16.03.2015    85330    1369    moolex    193    

Формирование договоров по шаблонам из Google Drive

Печатные формы документов Документооборот и делопроизводство v8 УТ11 КА2 Россия БУ УУ Абонемент ($m)

Основная идея: бухгалтер / кадровик / директор может вносить правки в шаблоны договоров без участия программиста. Пользователь получает возможность редактировать шаблоны на Google диске и тут же формировать договоры по исправленным шаблонам из 1С. Заполненный по шаблону договор сохраняется на Google диск. Вместо пары десятков внешних печатных форм, в вашей базе всего одна внешняя обработка. Обработка разрабатывалась под КА 2. Тестировалась на КА 2.4.9.82, УТ 11.4.5.32, УТ 11.4.9.98. Несложно адаптируется под другие БСП-Конфигурации.

2 стартмани

25.11.2019    7990    15    hlopik    20    

Отладка правил обмена КД2 для подсистемы БСП Обмен данными

Перенос данных из 1C8 в 1C8 v8 1cv8.cf Абонемент ($m)

Уже давно нельзя отлаживать правила обмена при помощи внешних файлов. Попробуем исправить это.

1 стартмани

27.05.2019    10343    10    fenixnow    5    

Выгрузка и загрузка данных XML с гибкими отборами

Обмен через XML Перенос данных из 1C8 в 1C8 v8 1cv8.cf Абонемент ($m)

Обработка выгрузки и загрузки данных через XML между идентичными конфигурациями с возможностью установки произвольных отборов на выгружаемые объекты.

1 стартмани

07.04.2019    13319    334    sapervodichka    7    

Соответствия объектов обмена Промо

Распределенная БД (УРИБ, УРБД) Перенос данных из 1C8 в 1C8 v8 КА1 Россия Абонемент ($m)

Обработка позволяет проверять, исправлять ошибки, добавлять и удалять соответствия объектов в обменах данными между конфигурациями на основе «Комплексной автоматизации 1.1» или похожими конфигурациям. Подходит для обменов с использованием регистра сведений «СоответствиеОбъектовДляОбмена».

2 стартмани

26.08.2016    19341    11    xxxelaaa    0    

Доработка функционала отправки дополнительных реквизитов 1С: ЭДО для Татнефть

Внешние источники данных Документооборот и делопроизводство Документооборот и делопроизводство v8 ERP2 БУ Абонемент ($m)

Подключаемое расширение к конфигурации ERP с функционалом отправки дополнительных реквизитов 1С ЭДО для Татнефть (№ и дата договора, подразделение, автор, примечание) в электронных документах Счет-фактуры и ТОРГ-12 Проверялось на 1С:ERP Управление предприятием 2.4.6.160.

2 стартмани

07.04.2019    7323    10    sapervodichka    6    

Слияние баз ERP (формирование остатков и перенос данных)

Обработка документов Перенос данных из 1C8 в 1C8 v8 ERP2 Абонемент ($m)

Обработка формирует в базе Источника документы ввода остатков на складах, в производстве, по ОС и НМА, остатки по счетам БУ, остатки по ЗУП. Далее в базу Приемник правилами обмена переносятся данные: НСИ, Заказы, Вводы остатков, Вводы остатков внеоборотных активов, Операции бух., Корректировка регистров, Данные ЗУП (Остатки ЗУП, НСИ, документы за период). Проверялось между 1C ERP 2.2.4.158 1С ERP 2.4.6.160.

5 стартмани

25.03.2019    6654    22    sapervodichka    6    

Перенос данных КА 1.1 -> КА 2

Перенос данных из 1C8 в 1C8 Обмен через XML v8 КА1 КА2 Россия Абонемент ($m)

Перенос данных КА 1.1 => КА 2 с помощью правил обмена данными в формате XML КД 2 (переносятся остатки, документы, справочная информация).

5 стартмани

20.03.2019    12903    233    gudogu    127    

Визуализация электронной подписи на исходящих документах в соответствии с ГОСТ Р 7.0.97-2016. Полная автоматизация

Печатные формы документов Документооборот и делопроизводство Документооборот и делопроизводство v8 ДО Россия Абонемент ($m)

Визуализация ЭЦП по ГОСТу Р 7.0.97-2016, предложенная в предыдущей статье (https://infostart.ru/public/931674/) на данную тему, очень прижилась у меня в организации. Начальник часть писем повелел подписывать ЭЦП и не тревожить его по пустякам. Но механизм подписи требовал некоторого количества ручных действий, а хочется полной автоматизации. Итак, постановка задачи: штамп должен позиционироваться сам, pdf-файл со штампом ЭЦП должен создаваться сам и в карточку исходящего документа тоже должен сам загружаться.

1 стартмани

19.02.2019    12050    45    soulner    33    

Ручная выгрузка и загрузка данных через универсальный обмен данными с настройками (расширение, платформа 8.3+)

Обработка документов Обработка справочников Обмен через XML Перенос данных из 1C8 в 1C8 v8 Розница УНФ ERP2 БП3.0 УТ11 КА2 ЗУП3.x Абонемент ($m)

Данное расширение (не требует изменения конфигураций) служит как надстройка для конфигураций, у которых обмен между базами происходит через универсальный формат (EnterpriseData), с использованием стандартных правил конвертации, которые уже есть в конфигурации. Интерфейс адаптирован для простых пользователей, сделан общий отбор по Организации для всех документов, имеется пару настроек для передачи в параметры конвертации, которые расположены в общем модуле конфигураций, а так же есть возможность выбора запуска - в фоне или в текущем сеансе. Теперь не нужно настраивать обмен между базами, для того чтоб просто перенести нужные документы. Подходит точно для УТ 11.4, БП 3.0.67, КА 2.4.5, Розница 2.2.9 (Обновление 1.2 от 02.03.2019)

2 стартмани

19.01.2019    17455    116    hakerxp    10    

Обмен без правил. От простого к сложному

Перенос данных из 1C8 в 1C8 v8 1cv8.cf Абонемент ($m)

Пишем обмен с нуля, разбираемя с разными способами сериализации, учимся редактировать XML документы, создаем XDTO и Web service, осваиваем Script variant - English.

1 стартмани

16.01.2019    20057    14    fr13    26    

Выгрузка данных из УТ 10.3 в БП 3.0 (своими руками) Промо

Перенос данных из 1C8 в 1C8 v8 УТ10 БП3.0 Россия Абонемент ($m)

Старая добрая, позабытая многими выгрузка из УТ 10.3 в БП 1.6. Ее еще можно оживить, и она послужит на благо всем желающим, всем уставшим от автоматических обменов.

3 стартмани

30.10.2014    37114    175    TESL    40    

Выполнение запроса в другой базе 1С без com-соединения. HTTP-сервис

Перенос данных из 1C8 в 1C8 v8 1cv8.cf Абонемент ($m)

Выполнение любого запроса с параметрами из одной базы 1С в другую. Используя HTTP-сервис. Посредством POST-запроса и JSON.

1 стартмани

30.11.2018    16837    20    John_d    21    

Пример получения данных из другой базы 1С через Web-сервис

Перенос данных из 1C8 в 1C8 v8 Россия Абонемент ($m)

В данной статье описан пример получения данных справочника из другой базы 1С через Web-сервис.

1 стартмани

11.11.2018    23295    21    flyDrag    29    

Способы оптимизации переносов данных

Перенос данных из 1C8 в 1C8 Интеграция v8 КД Абонемент ($m)

Хочу рассказать вам про способы оптимизации разработки правил обмена в программе «Конвертация данных» второй редакции. Казалось бы, про эту программу и разработку в ней правил конвертации уже сказано все, что можно. Появились уже более современные и быстрые технологии. Почему же все еще она? Дело в том, что «Конвертация данных» второй редакции все еще актуальна для огромного круга задач. Она имеет очень широкую функциональность и позволяет реализовывать сложные алгоритмы. Годы идут, а люди продолжают ей пользоваться и у них возникает много вопросов по этой программе. Возможно, в будущем вы тоже будете заниматься такими проектами и столкнетесь с задачами, похожими на те, про которые я собираюсь рассказать. Мне хочется вам в этом помочь.

1 стартмани

02.08.2018    15514    11    primat    7    

Интерфейс сопоставления объектов для обмена (для типового регистра СоответствиеОбъектовДляОбмена) Промо

Инструментарий разработчика Универсальные обработки Перенос данных из 1C8 в 1C8 v8 КА1 БП2.0 ЗУП2.5 УТ10 УПП1 Абонемент ($m)

Вы внедряете обмен данными между двумя типовыми или основанными на типовых БД и вам необходим инструмент, чтобы сопоставить между собой справочники этих конфигураций? Вы хотите навести порядок в обмене данными, потому что вам надоело вылавливать дублирующиеся объекты? Вам очень хочется перепоручить сопоставление объектов обменивающихся баз пользователям, но нет подходящего и понятного пользователям интерфейса? Тогда вам нужна именно эта обработка!

4 стартмани

11.11.2015    35839    131    catsam    8    

Опыт проведения сложных переносов данных на 1С

Перенос данных из 1C8 в 1C8 Интеграция v8 КД Абонемент ($m)

В статье я расскажу про опыт сложных переносов на платформе 1С:Предприятие. Она будет адресована в первую очередь разработчикам 1С, которые уже имеют опыт использования методики «Конвертация данных» (как второй, так и третьей редакции) – я думаю, это большинство из нас. • Я расскажу про различные методики организации переносов данных. • Мы рассмотрим рекомендуемые способы оптимизации правил конвертации, которые позволят вам быстрее выполнять свои переносы. • Также мы разберем, какие могут возникнуть сложности в ходе переноса данных. • Я покажу сравнительный анализ по ряду параметров инструментов «Конвертация данных» второй редакции и третьей, которая вышла уже более года назад.

1 стартмани

30.07.2018    33032    8    primat    13    

Правила переноса документов из ЗУП 2.5 в ЗУП 3.1

Обмен через XML Перенос данных из 1C8 в 1C8 Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 v8::СПР ЗУП2.5 ЗУП3.x Россия БУ Абонемент ($m)

Перенос документов, справочников и планов видов расчета из конфигурации 1С ЗУП 2.5 в ЗУП 3.1.

3 стартмани

28.03.2018    25664    408    Cobranet123    64    

Простая подсистема согласования

Рабочее место Документооборот и делопроизводство Документооборот и делопроизводство v8 v8::УФ 1cv8.cf УУ Абонемент ($m)

Простая система согласования (утверждения), с простой установкой на любую конфигурацию с управляемыми формами.

1 стартмани

27.03.2018    15080    59    eugenevk    23    

Синхронизация (выгрузка) данных ЗУП 3.1 - БП 2.0, УПП 1.3

Перенос данных из 1C8 в 1C8 Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 v8::БУ v8::СПР БП2.0 ЗУП3.x Россия БУ Абонемент ($m)

Подобная выгрузка не была предусмотрена разработчиками 1С, поэтому и существует эта публикация. Поддерживается выгрузка оценочных обязательств и резервов отпусков. Непосредственная выгрузка в базу Бухгалтерии. Решение проблем с COM-соединением одной кнопкой.

3 стартмани

22.03.2018    36532    617    diso    178    

Организация обмена с базой филиала (розничного магазина) в торговой сети через XML (универсальный обмен)

Обмен через XML Перенос данных из 1C8 в 1C8 Розничная торговля Розничная торговля v8 КД УТ11 Розничная и сетевая торговля (FMCG) Абонемент ($m)

В статье по шагам рассматривается создание обмена между центральной базой и базами филиалов на базе конфигурации УТ 11. Для решения поставленной задачи было решено не использовать РИБ, т.к. требуется односторонний обмен ограниченным набором данных, к тому же по определенным условиям. Обмен реализован на основе типовой синхронизации на основе универсального обмена в формате EnterpriseData. Данная публикация может быть полезна внедренцам, которые работают с торговыми сетями, в том числе по модели франчайзинга.

1 стартмани

26.02.2018    34024    13    Kutuzov    18    

[УТ 11][БП 3.0] Перенос данных из БП 3.0 в УТ 11 (начальное заполнение УТ 11 по данным БП 3.0)

Перенос данных из 1C8 в 1C8 v8 БП3.0 УТ11 Россия УУ Абонемент ($m)

Перенос данных из БП 3.0 в Ут 11 для первоначального заполнения УТ данными из БП. 31.01.2020 Версия 2.8.7.0 БП 3.0.75.70 платформа 8.3.16.1148. Исправлено подключение COM, более ничего...и это-то по многочисленным просьбам трудящихся... Нет пока времени (ну, или клиента) чтобы заняться этой обработкой...

1 стартмани

29.01.2018    34957    454    Alex_E    144    

Проверка данных после неполного ("нового") переноса из ЗУП 2.5 в ЗУП 3.1 Промо

Зарплата Бухгалтерский учет Перенос данных из 1C8 в 1C8 Зарплата v8 v8::СПР ЗУП3.x Россия БУ Абонемент ($m)

Описаны данные, которые необходимо проверить после неполного ("нового") переноса из ЗУП 2.5 в ЗУП 3.1. Описано, на что необходимо обратить внимание, где найти перенесенные данные, что НЕ переносится, где найти настройки.

1 стартмани

17.01.2018    26437    140    btydj    3    

Правила переноса документов из ЗУП 2.5 в ЗУП 3.1

Перенос данных из 1C8 в 1C8 Обмен через XML Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 v8::СПР ЗУП3.x Россия БУ Абонемент ($m)

Перенос документов из ЗУП 2.5 в ЗУП 3.1 - позволяет снизить объем работ при опытной эксплуатации ЗУП 3.1 параллельно с ЗУП 2.5.

1 стартмани

04.12.2017    30044    494    AntonH851    38    

1С:Конвертация данных 2.0. Анализ состава выгруженных данных из базы источника до загрузки в базу-приемник

Перенос данных из 1C8 в 1C8 Перенос данных из 1С7.7 в 1C8.X v8 КД БП3.0 ЗУП3.x Россия Абонемент ($m)

Обработка анализирует файл выгрузки данных конвертации и формирует дерево выгруженных объектов по категориям с возможностью просмотра выгруженных реквизитов (свойств). Идеально подходит для анализа выгруженных данных при переходе на ЗУП 3.1 или Бухгалтерия 3.0 с ранних версий.

1 стартмани

16.11.2017    14097    80    leosoft    4    

Механизмы и транспорт обмена данными. Пример создания в КД 2.1 правил обмена данными ЗУП 2.5 -> БП 3.0. Выгрузка ведомостей и банковских счетов. Передача параметров обмена из Источника в Приемник. ВыгрузитьПоПравилу(). ПередатьОдинПараметрВПриемник().

Обмен через XML Перенос данных из 1C8 в 1C8 v8 ЗУП2.5 КД БП3.0 Абонемент ($m)

В статье рассказываю: 1) о механизмах и транспорте обмена данными, где одной из сторон обмена выступает конфигурация на базе 1С, и о том, какой транспорт и в каких случаях лучше использовать 2) о решении задачи выгрузки данных документа «Зарплата к выплате организаций» (с выгрузкой банковский счетов физ лиц документа) из ЗУП 2.5.123.1 (далее Источник) в БП КОРП 3.0.52.39 (далее Приемник) путем создания правил обмена данными с использованием конфигурации «Конвертация данных» (далее просто КД) ред. 2.1.8.2. для (далее ЗкВО) 3) о тестирование полученных правил обмена данными.

1 стартмани

03.11.2017    29734    5    RailMen    5    

Выгрузка - загрузка данных в XML с отбором по организации Промо

Обмен через XML Перенос данных из 1C8 в 1C8 v8 1cv8.cf Абонемент ($m)

Выгрузка - загрузка данных в XML с отбором по организации (УФ)

1 стартмани

25.05.2014    44243    297    buganov    42    

Синхронизация данных по правилам КД2.0

Перенос данных из 1C8 в 1C8 v8 1cv8.cf Абонемент ($m)

Новый инструмент для сравнения и загрузки данных, сочетающий в себе: гибкость запросов (используются для сопоставления объектов); наглядный вывод отличий; удобный отбор загружаемых данных; возможность пообъектной синхронизации двух баз по правилам КД2 с помощью вызова обработки "Универсальный обмен XML" в базе-источнике через COM-соединение.

1 стартмани

27.08.2017    21637    108    vikad    35    

Правила обмена ЗУП 3.1 - БП 2.0 и ЗУП 3.1 - УПП 1.3 (отражение, ведомости и справочники)

Перенос данных из 1C8 в 1C8 Обмен через XML Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 v8::БУ v8::СПР БП2.0 БП3.0 ЗУП3.x Россия БУ Абонемент ($m)

Правила обмена для выгрузки документов "Отражение зарплаты в бухучете", "Ведомость в банк", "Ведомость в кассу", справочников "Сотрудники" и "Физические лица"

1 стартмани

01.08.2017    71742    1533    forseil    205    

Знакомство с 1С:Документооборот. История автоматизации и доработок. Печатная форма Лист согласования

Практика программирования Документооборот и делопроизводство Документооборот и делопроизводство v8 ДО УУ Абонемент ($m)

Документооборот 2.1.10.2 ПРОФ, КОРП. История автоматизации и доработок. Ввод на основании внутреннего документа из задачи согласование с переносом прикрепленных файлов(копировать и вставить файлы). ПФ Лист согласования для процесса Согласование и для справочника Внутренние документы(печатается с историей). Автоматическая загрузка справочника по com-соединению из другой базы. Печатные формы работают и на последнем релизе 2.1.20.5.

1 стартмани

04.07.2017    18894    31    SPonomareff    17    

Перенос справочников и документов из УТ 10.3 в БП 3.0 Промо

Перенос данных из 1C8 в 1C8 v8 УТ10 БП3.0 Россия БУ НУ УУ Абонемент ($m)

Синхронизация справочников и документов из Управление торговлей 10.3 в Бухгалтерию предприятия 3.0. Обработка не затрагивает штатный механизм. Подключение и перенос документов происходит посредством OLE. Без ввода начальных остатков.

10 стартмани

25.07.2017    19916    14    2casp    5    

«Горыныч - то НЕ НАСТОЯЩИЙ!» … или О Конвертации Данных ред.3 (КД 3) и обменах в универсальном формате Enterprise Data… доступным русско-народным языком

Внешние источники данных Обмен через XML Перенос данных из 1C8 в 1C8 v8 КД Абонемент ($m)

Тем, кто хочет быстро разобраться с темой инструмента Конвертация данных 3.0 и технологией обмена по новому формату 1С, активно применяемому во всех новых конфигурациях от 1С на БСП, расширяющем возможности интеграции, пакет полезных материалов.

1 стартмани

13.06.2017    19220    138    Davlad_A    16    

Согласование (подсистема). Для любого справочника и документа в 1С. Встраивается в любые конфигурации

Управление бизнес-процессами (BPM) Обработка документов Обработка справочников Документооборот и делопроизводство Документооборот и делопроизводство v8 1cv8.cf БП3.0 КА2 УУ Абонемент ($m)

Подсистема для согласования в 1С. Для настройки нового согласования не требуется программировать, все делается в режиме исполнения. Открытый код. Бизнес-процессы. Документооборот. Проект выложен на GitHub.

1 стартмани

25.08.2016    47069    246    BlizD    198    

Перенос объектов по OLE из идентичной конфигурации

Перенос данных из 1C8 в 1C8 v8 1cv8.cf Россия Абонемент ($m)

Перенос по OLE справочников, документов и пользователей из базы источника с идентичной конфигурацией без использования правил обмена, поиск по реквизитам, замена ГУИД, сохранение настроек в файл

1 стартмани

10.07.2016    14268    120    slava_1c    8    

Правила конвертации документов ЗУП 2.5 - ЗУП 3.1 Промо

Обмен через XML Зарплата Перенос данных из 1C8 в 1C8 Зарплата v8 v8::СПР ЗУП2.5 ЗУП3.x Россия БУ Абонемент ($m)

Правила конвертации документов ЗУП 2.5 - ЗУП 3.1. Позволяют вести параллельную работу в базах ЗУП редакций 2,5 и 3.1.

10 стартмани

06.03.2018    34874    151    kostya_whiskas    24    

Правила обмена УТ 11 -> УНФ 1.6

Перенос данных из 1C8 в 1C8 v8 УТ10 УНФ Абонемент ($m)

Потребовалось перевести работу из УТ 11 на УНФ 1.6 с переносом данных, введенных с начала года. Типовые правила отсутствуют, поэтому разработали собственные. Замечу, что правила не универсальные, т.е. не подстраиваются под разные учетные политики, вероятно, некоторые моменты вам придется поменять, но на 90% они подойдут (Конфигурации УТ 11.1.10.185 и УНФ 1.6.5.28) После переноса документы нужно будет провести. (Меню 1С - Все функции - Стандартные - Проведение документов - Провести все ранее проведенные)

2 стартмани

09.06.2016    26580    125    sapervodichka    16    

Перенос данных из ЗУП 2.5 в ЗУП 3.1

Перенос данных из 1C8 в 1C8 Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 v8::СПР ЗУП2.5 ЗУП3.x БУ Абонемент ($m)

Обработка предназначена для переноса некоторых данных из ЗУП 2.5 в ЗУП 3.1 через COM-соединения. Обработка была написана потому, что типовые правила переноса не предоставляют возможности переносить данные по отдельности, а некоторые данные не переносят вовсе. Тестировалась на версии 3.1.12.113 (8.3.15.1830).

1 стартмани

26.05.2016    40021    733    yojeeg    90    

Перенос НФА (ОС и МЗ) между учреждениями/базами через документы списания и поступления [БГУ 1.0] Промо

Перенос данных из 1C8 в 1C8 Обработка документов Учет ОС и НМА Учет ОС и НМА v8 v8::БУ БГУ Государственные, бюджетные структуры Россия БУ Госбюджет Абонемент ($m)

Обработка выполняет перенос основных средств/материалов между учреждениями/базами через документы списания НФА и безвозмездного получения в другом учреждении/базе данных.

10 стартмани

18.09.2014    38711    45    qwinter    31    

Выгрузка/загрузка данных в формате JSON v 1.0.6

Распределенная БД (УРИБ, УРБД) Перенос данных из 1C8 в 1C8 v8 1cv8.cf Абонемент ($m)

Обработка предназначена для обмена данными между схожими конфигурациями в формате JSON. Этот формат обладает рядом существенных преимуществ по сравнению с xml и прочими популярными форматами. В отличие от существующих аналогов, обработка не использует никаких дополнительных библиотек. (де)Сериализация всех объектов происходит средствами встроенного языка и методов ЗаписатьJSON() и ПрочитатьJSON(). Работает на платформе версии не ниже 8.3.6.

3 стартмани

27.01.2016    41359    321    kser87    41    

[COM] Перенос данных через COMConnector

Перенос данных из 1C8 в 1C8 v8 1cv8.cf Россия Абонемент ($m)

Обработка обмена между двумя информационными базами схожей (не обязательно совпадающей) структуры. Изначально была заточена под бухгалтерию предприятия, сейчас используется для для обменов через COM любых конфигураций с режимом запуска "Управляемое приложение". Ближайший аналог - выгрузка-загрузка XML, но здесь нет промежуточных файлов выгрузки/загрузки, и обмен не прекращается в случае, когда состав реквизитов источника и приёмника различен!!! 22.05.2020 Версия 5.2.3.4 Исправлена ошибка в таблице соответствия планов счетов, любезно подсказанная Fox_65. Все реквизиты таблицы соответствия теперь с типом строка, чтобы избежать в дальнейшем повторения этой ошибки, если обработку вдруг будет сохранена в конфигурации, не имеющей Плана счетов Хозрасчтный. Соответственно изменены заполнеие таблицы соответствия счетов и поиск счетов между базами. Из нового - добавлен возможность переноса Счетов на оплату покупателю из КА 1.1 в Заказ клиента КА 2.4 (случилась такая хотелка у клиента) (тестировалось на платформе 8.3.17.1386, БП 3.0.77.89 )

2 стартмани

23.11.2015    45990    630    Alex_E    201    

Создание договоров по шаблонам Word в УТ 11.2, БП 3.0 с возможностью хранения в справочнике "Файлы"

Универсальные печатные формы Универсальные обработки Документооборот и делопроизводство Документооборот и делопроизводство v8 БП3.0 УТ11 УУ Абонемент ($m)

Публикация предназначена тем, кто ведет договоры в УТ 11 не только в справочнике "Договоры с контрагентами", но также формирует и согласовывает с контрагентами договоры в формате Word (*.doc). А так как программисты люди ленивые и я не являюсь исключением в этом (хорошем) смысле :), была создана эта печатная форма. Но это не простая печатная форма, а инструмент, который позволяет на основании шаблона, хранящегося в информационной базе в справочнике "Файлы", быстро заполнять и сохранять тут же в справочник "Файлы", но в другую папку, уже заполненный на основании шаблона договор в формате Word.

1 стартмани

08.10.2015    31402    253    Diversus    60    

УПД за поставщика c подписями и факсимиле для БП 3.0 Промо

Печатные формы документов Документооборот и делопроизводство Оптовая торговля Документооборот и делопроизводство Оптовая торговля v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Внешняя печатная форма для печати - "Универсальный передаточный документ" за поставщика. ВПФ (с формой и без) в форме заполняются должности и фамилии и происходит заполнение полей 10,13, 15,18.Так же есть возможность хранить и выводить на печать подписи руководителя и глав.бухгалтера поставщика. Внесены изменения под требования конфигураций выше 3.0.67.38 (НДС20%). Версия 0.2 без формы выбора подписантов(будет полезна тем у кого ответственные лица неизменные).

5 стартмани

19.03.2015    75966    959    kn    102    

Управление изменениями в планах обмена (Управляемое приложение) v 1.0

Распределенная БД (УРИБ, УРБД) Внешние источники данных Перенос данных из 1C8 в 1C8 v8 1cv8.cf Абонемент ($m)

Простая в использовании и наглядная обработка для регистрации изменений или отмены регистрации в планах обмена используя гибкие возможности отбора СКД.

2 стартмани

15.08.2015    28248    45    kser87    3    

Регистрация и согласование договоров, редакция 2.0

Документооборот и делопроизводство Управленческий учет (прочее) v8 УУ Абонемент ($m)

Конфигурация "Регистрация и согласование договоров" является готовым решением для управления и учета договоров на предприятии. Позволяет организовать единую информационную систему регистрации и согласования. Включает CRM подсистему.

1000 руб.

26.05.2015    16747    19    5    

Приемная руководителя, редакция 1.1

Документооборот и делопроизводство Управленческий учет (прочее) v8 Абонемент ($m)

Приемная руководителя, редакция 1.1. Конфигурация на управляемых формах (интерфейс - Такси) с открытым кодом, создана для секретарей.

1500 руб.

19.05.2015    25483    20    6    

Перенос данных из Бухгалтерии 2.0 в Бухгалтерию 3.0

Перенос данных из 1C8 в 1C8 Обмен через XML v8 БП2.0 БП3.0 Россия БУ Абонемент ($m)

Перенос данных и остатков с Бухгалтерии 2.0 в Бухгалтерию 3.0 с помощью универсального обмена данными XML.

1 стартмани

30.12.2014    42689    297    sergeyzhuravlev    10